Unbounded request body read in Apache Struts REST plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-770.
Summary
Apache Struts versions from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0 and from 7.0.0 through 7.3.0 are affected. The REST plugin reads a request body into memory without any bound on its size (CWE-770). A remote attacker with low privileges can send one large request that makes the server allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. Applications that do not use the REST plugin are not affected.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | 2.1.8 – 2.3.37; 2.5.0 – 2.5.33; 6.0.0 – 6.11.0; 7.0.0 – 7.3.0 | — | No fix listed | CNA |
- Apache Struts VendorApache Affected 2.1.8 – 2.3.37; 2.5.0 – 2.5.33; 6.0.0 – 6.11.0; 7.0.0 – 7.3.0 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* | 2.1.8 – 2.3.37; 2.5.0 – 2.5.33; 6.0.0 to before 6.12.0; 7.0.0 to before 7.4.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* Versions 2.1.8 – 2.3.37; 2.5.0 – 2.5.33; 6.0.0 to before 6.12.0; 7.0.0 to before 7.4.0 Vulnerable ·Apache
Remediation
Upgrade Apache Struts to version 6.12.0 or 7.4.0, which fix the issue.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-05 Threatist record created from CVE-2026-104713
- 2026-10-06 Alias added: GHSA-3fxc-fh79-w9fr
- 2026-10-06 CVSS score added · CISA ADP
- 2026-10-06 CISA SSVC decision points changed
- 2026-10-09 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2026-104713 · CVE Program
- CVE-2026-104713 · NVD
- FIRST EPSS
- GHSA-3fxc-fh79-w9fr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences