Dolibarr lets read-only users modify extrafield values
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
Dolibarr ERP CRM before 24.0.2 has an incorrect authorization flaw (CWE-863) in htdocs/core/ajax/updateextrafield.php. The script checks only read permission before writing extrafield values. An authenticated user with read-only access can persistently modify extrafields on viewable third parties, products, members, projects or contacts.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Dolibarr ERP CRM before 24.0.2 contains an incorrect authorization vulnerability in htdocs/core/ajax/updateextrafield.php that checks only read permission before writing extrafield values. Authenticated users with read-only access can POST objectType, objectId, field and value parameters to persistently modify extrafields on viewable third parties, products, members, projects or contacts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Dolibarr to version 24.0.2, which fixes this issue. Installations running versions before 24.0.2 are affected.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA dolibarr (Dolibarr) Fixed in 24.0.2
Timeline
- 2026-10-09 Threatist record created from CVE-2026-107706
References
More Dolibarr vulnerabilities
- TI-2022-21049 Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API. CVSS 3.1CRITICAL 9.8
- TI-2022-03742 SQL Injection in dolibarr/dolibarr CVSS 3.1CRITICAL 9.8
- TI-2023-14191 Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an… CVSS 3.1HIGH 8.8
- TI-2018-15582 Dolibarr ERP CRM 7.0.3 Remote Code Execution via install/step1.php CVSS 4.0CRITICAL 9.3
- TI-2018-07157 SQL injection vulnerability in Dolibarr before 7.0.2 allows remote attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2019-15505 Dolibarr ERP/CRM 10.0.1 SQL Injection via elemid CVSS 4.0HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences