Reflected cross-site scripting in Kubio AI Page Builder for WordPress
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Kubio AI Page Builder plugin for WordPress by Extend Themes is affected through version 2.9.3. Improper neutralization of input during web page generation (CWE-79) allows reflected cross-site scripting. A remote attacker without privileges can inject script that runs in a victim's browser if the victim interacts with a crafted page, and the impact can reach beyond the plugin.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Extend Themes Kubio AI Page Builder kubio allows Reflected XSS.This issue affects Kubio AI Page Builder: from n/a through 2.9.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| extendthemes | Kubio AI Page Builder | up to 2.9.3 | — | No fix listed | CNA |
- Kubio AI Page Builder Vendorextendthemes Affected up to 2.9.3 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for Kubio AI Page Builder.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-09 Threatist record created from CVE-2026-94167
- 2026-10-09 Alias added: GHSA-w8fw-hg3r-5r6w
- 2026-10-10 CISA SSVC decision points changed
- 2026-10-10 Priority changed: MEDIUM → LOW
More extendthemes vulnerabilities
- TI-2025-02014 Kubio AI Page Builder <= 2.5.1 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2022-04358 Materialis Companion < 1.3.40 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-04096 Mesmerize Companion < 1.6.135 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2019-15245 Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-54440 WordPress Lead Generation Contact Widget & AI Chatbot: Chat Button, Phone Call, Telegram… CVSS 3.1HIGH 7.5
- TI-2024-22269 WordPress Teluro theme <= 1.0.31 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2026-94167 · CVE Program
- CVE-2026-94167 · NVD
- FIRST EPSS
- GHSA-w8fw-hg3r-5r6w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences