Stored cross-site scripting in SureDash via image alt attribute
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The SureDash plugin for WordPress is affected in all versions up to and including 1.12.1. Insufficient input sanitization and output escaping (CWE-79) let an authenticated attacker with subscriber-level access or higher store script in community post content through an image alt attribute. The entity-encoded payload passes server-side wp_kses filtering, which permits img alt attributes without normalizing entities, and is decoded client-side when GLightbox assigns the alt property to innerHTML, so the script runs whenever a user opens an affected page.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The SureDash – Community, Courses & Member Dashboard plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via Image 'alt' Attribute in Community Post Content in all versions up to, and including, 1.12.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The entity-encoded payload bypasses server-side wp_kses filtering because kses permits the img/alt tag combination and does not normalize entities inside attribute values; the decode occurs client-side when GLightbox reads the .alt DOM property and assigns the result to innerHTML.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Brainstorm Force | SureDash – Community, Courses & Member Dashboard | up to 1.12.1 | — | No fix listed | CNA |
- SureDash – Community, Courses & Member Dashboard VendorBrainstorm Force Affected up to 1.12.1 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for SureDash.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-10 Threatist record created from CVE-2026-102774
- 2026-10-10 Alias added: GHSA-hv84-qp5f-whrj
- 2026-10-11 CISA SSVC decision points changed
- 2026-10-11 Priority changed: MEDIUM → LOW
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a8b5b389-85f4-4cc5-9796-55b611af7916?source=cve
- https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/assets/js/minified/lightbox.min.js
- https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/core/routers/misc.php#L59
- https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/core/routes.php#L101
- https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/inc/services/router.php#L127
- https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/inc/utils/post-meta.php#L377
- https://plugins.trac.wordpress.org/changeset?reponame=&new=3724179%40suredash%2Ftags%2F1.12.2&old=3694773%40suredash%2Ftags%2F1.12.0
More Brainstorm Force vulnerabilities
- TI-2025-19878 WordPress SureTriggers <= 1.0.82 - Privilege Escalation Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-02708 Incorrect comparison in Brainstorm Force OttoKit: All-in-One Automation Platform CVSS 3.1HIGH 8.1
- TI-2025-05347 SureForms < 1.7.2 - Reflected XSS CVSS 3.1MEDIUM 5.8
- TI-2020-18849 Spectra < 1.15.0 - Contributor+ Stored Cross-Side Scripting CVSS 3.1MEDIUM 5.4
- TI-2025-03050 SureForms < 1.4.4 - Contributor+ Settings Update CVSS 3.1MEDIUM 4.9
- TI-2025-11950 Starter Templates <= 4.4.41 - Authenticated (Author+) Arbitrary File Upload via WXR Upload Bypass CVSS 3.1HIGH 8.8
Sources
- CVE-2026-102774 · CVE Program
- CVE-2026-102774 · NVD
- FIRST EPSS
- GHSA-hv84-qp5f-whrj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences