Decompression bomb denial of service in Gumlet php-image-resize
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Gumlet php-image-resize before 3.0.1 contains a denial of service flaw because the ImageResize constructor in lib/ImageResize.php passes images to GD imagecreatefrom* functions without pixel limits. This is improper handling of highly compressed data (CWE-409). A remote, unauthenticated attacker can upload small, highly compressed images that decode to large bitmaps, exhausting PHP memory and terminating the worker process.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Gumlet php-image-resize before 3.0.1 contains a denial of service vulnerability because the ImageResize constructor in lib/ImageResize.php passes images to GD imagecreatefrom* functions without pixel limits. Remote attackers can upload small, highly compressed images that decode to large bitmaps, exhausting PHP memory and terminating the worker process.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update php-image-resize to version 3.0.1 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA php-image-resize (gumlet) Fixed in 3.0.1
Timeline
- 2026-10-12 Threatist record created from CVE-2026-109398
- 2026-10-12 Alias added: GHSA-f678-5vxr-2r99
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-13 CISA SSVC decision points changed
- 2026-10-13 Priority changed: LOW → HIGH
References
Patch 2
More gumlet vulnerabilities
- TI-2024-12617 Gumlet Video <= 1.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2026-109398 · CVE Program
- CVE-2026-109398 · NVD
- FIRST EPSS
- GHSA-f678-5vxr-2r99 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences