Read the docs

Missing authorization in Frappe ERPNext lets users create and modify records

Priority LOW 31CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

Frappe ERPNext before 15.119.0 and from 16.0.0-beta.1 before 16.31.0 has a missing authorization flaw (CWE-862) in certain endpoints that do not enforce proper permission checks. An authenticated attacker can send requests to these endpoints to create records and modify data beyond their permitted role, bypassing role-based access restrictions. The CVSS 4.0 vector requires low privileges and no user interaction, and impacts integrity of the vulnerable system.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

Frappe ERPNext before 15.119.0 and 16.x before 16.31.0 contains a missing authorization vulnerability in certain endpoints that fail to enforce proper permission checks. Authenticated attackers can send requests to these endpoints to create records and modify data beyond their permitted role, bypassing intended role-based access restrictions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00247 16th percentileScored 2026-11-07
Fix Fixed erpnext (frappe): 15.119.0, 16.31.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
frappeerpnextbefore 15.119.0; 16.0.0-beta.1 to before 16.31.015.119.0, 16.31.0Patch availableCNA
  • erpnext Vendorfrappe Affected before 15.119.0; 16.0.0-beta.1 to before 16.31.0 Fixed in 15.119.0, 16.31.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:frappe:erpnext:*:*:*:*:*:*:*:*——frappe
  • cpe:2.3:a:frappe:erpnext:*:*:*:*:*:*:*:* Versions — — ·frappe

Remediation

Upgrade ERPNext to version 15.119.0 or 16.31.0, which fix the flaw in the 15.x and 16.x branches respectively.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA erpnext (frappe) Fixed in 15.119.0, 16.31.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    frappe erpnext 15.119.0, 16.31.0

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2026-71412 Stored cross-site scripting in Frappe ERPNext enables account takeoverPriority LOW 36
    • TI-2026-71403 Missing authorization in Frappe ERPNext exposes valuation dataPriority LOW 31
    • TI-2026-71413 Frappe ERPNext Missing Authorization in Transactional Email EndpointsPriority LOW 23

Timeline

  1. 2026-10-13 Threatist record created from CVE-2026-109645
  2. 2026-10-13 Alias added: GHSA-2fwf-v7xj-x7wp
  3. 2026-10-13 Priority changed: MEDIUM → LOW
  4. 2026-10-18 CISA SSVC decision points changed

References

  • TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
  • TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
  • TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
  • TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
  • TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
  • TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
See all 321 →

Sources