Read the docs
TI-2026-71484 Aliases CVE-2026-78335GHSA-fqqc-43f5-5hmg

Incorrect authorization in GitLab lets tokens modify out-of-scope integrations

Priority LOW 19CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.

Summary

GitLab CE and EE from 19.1 before 19.2.8, from 19.3 before 19.3.5, and from 19.4 before 19.4.2 contain incorrect authorization checks (CWE-863). Under certain conditions, an authenticated user with a project-scoped fine-grained Personal Access Token can modify integrations that belong to a group outside the token's scope. CISA has not listed the issue in KEV, though the references include a public exploit link.

Written with Claude Haiku 5.5 from the sources below · 2026-10-27

Description from the CNA

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user holding a project-scoped fine-grained Personal Access Token to modify integrations belonging to a group outside the token's scope, due to incorrect authorization checks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0019 8th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed GitLab (GitLab): 19.2.8, 19.3.5, 19.4.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitLabGitLab19.1 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.219.2.8, 19.3.5, 19.4.2Patch availableCNA
  • GitLab VendorGitLab Affected 19.1 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 Fixed in 19.2.8, 19.3.5, 19.4.2 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*19.1.0 to before 19.2.8VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*19.1.0 to before 19.2.8VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*19.3.0 to before 19.3.5VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*19.3.0 to before 19.3.5VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*19.4.0 to before 19.4.2VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*19.4.0 to before 19.4.2VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.1.0 to before 19.2.8 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.1.0 to before 19.2.8 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab

Remediation

Upgrade GitLab to 19.2.8, 19.3.5, or 19.4.2, depending on the release branch in use.

Written with Claude Haiku 5.5 from the sources below · 2026-10-27

  • Fix · CNA GitLab (GitLab) Fixed in 19.2.8, 19.3.5, 19.4.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    GitLab 19.2.8, 19.3.5, 19.4.2

    23 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM, 21 LOW

    Other records, highest priority first

    • TI-2026-71508 Integer overflow in GitLab allows code execution on the serverPriority CRITICAL 100
    • TI-2026-71506 Cross-site scripting in GitLab syntax-highlighted outputPriority MEDIUM 40
    • TI-2026-71475 Permissive regular expression in GitLab lets attackers poison cached filesPriority LOW 38

Timeline

  1. 2026-10-13 Threatist record created from CVE-2026-78335
  2. 2026-10-13 Alias added: GHSA-fqqc-43f5-5hmg
  3. 2026-10-16 CISA SSVC decision points changed

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources