Incorrect authorization in GitLab lets tokens import projects into groups
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
GitLab CE/EE from 18.9 before 19.2.8, from 19.3 before 19.3.5, and from 19.4 before 19.4.2 has incorrect authorization of the import target namespace (CWE-863). Under certain conditions, an authenticated user with a fine-grained Personal Access Token scoped only to user-boundary import permissions can import projects into group namespaces beyond the token's intended scope. The CVSS 3.1 vector rates the attack as high complexity with low privileges required, and the impact as low integrity loss only. The references include an exploit link, but CISA does not list the flaw in KEV.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
Description from the CNA
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.9 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with a fine-grained Personal Access Token scoped only to user-boundary import permissions to import projects into group namespaces beyond the token's intended scope, due to incorrect authorization of the import target namespace.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 18.9 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 | 19.2.8, 19.3.5, 19.4.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 18.9 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 Fixed in 19.2.8, 19.3.5, 19.4.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.9.0 to before 19.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.9.0 to before 19.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.3.0 to before 19.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.3.0 to before 19.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.4.0 to before 19.4.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.4.0 to before 19.4.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.9.0 to before 19.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.9.0 to before 19.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
Remediation
Upgrade GitLab to 19.2.8, 19.3.5, or 19.4.2, the fixed version for each affected branch.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
- Fix · CNA GitLab (GitLab) Fixed in 19.2.8, 19.3.5, 19.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.2.8, 19.3.5, 19.4.2
23 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM, 21 LOW
Other records, highest priority first
- TI-2026-71508 Integer overflow in GitLab allows code execution on the serverPriority CRITICAL 100
- TI-2026-71506 Cross-site scripting in GitLab syntax-highlighted outputPriority MEDIUM 40
- TI-2026-71475 Permissive regular expression in GitLab lets attackers poison cached filesPriority LOW 38
Timeline
- 2026-10-13 Threatist record created from CVE-2026-82632
- 2026-10-13 Alias added: GHSA-f8h6-2x47-crgv
- 2026-10-16 CISA SSVC decision points changed
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-82632 · CVE Program
- CVE-2026-82632 · NVD
- FIRST EPSS
- GHSA-f8h6-2x47-crgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences