GitLab maintainers can remove protected package metadata
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
GitLab CE/EE from 17.6 before 19.2.8, from 19.3 before 19.3.5, and from 19.4 before 19.4.2 is affected. Improper authorization checks let an authenticated user with maintainer-role permissions remove certain package registry metadata that package protection rules restrict to higher roles. The flaw is classified as CWE-863. Exploiting it requires high privileges and only works under certain conditions, and it can affect integrity only.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
Description from the CNA
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.6 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with maintainer-role permissions to remove certain package registry metadata that package protection rules restrict to higher roles, due to improper authorization checks.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 17.6 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 | 19.2.8, 19.3.5, 19.4.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 17.6 to before 19.2.8; 19.3 to before 19.3.5; 19.4 to before 19.4.2 Fixed in 19.2.8, 19.3.5, 19.4.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.6.0 to before 19.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.6.0 to before 19.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.3.0 to before 19.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.3.0 to before 19.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.4.0 to before 19.4.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.4.0 to before 19.4.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.6.0 to before 19.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.6.0 to before 19.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.3.0 to before 19.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.4.0 to before 19.4.2 Vulnerable ·GitLab
Remediation
GitLab CE/EE is fixed in versions 19.2.8, 19.3.5, and 19.4.2.
Written with Claude Haiku 5.5 from the sources below · 2026-10-27
- Fix · CNA GitLab (GitLab) Fixed in 19.2.8, 19.3.5, 19.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.2.8, 19.3.5, 19.4.2
23 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM, 21 LOW
Other records, highest priority first
- TI-2026-71508 Integer overflow in GitLab allows code execution on the serverPriority CRITICAL 100
- TI-2026-71506 Cross-site scripting in GitLab syntax-highlighted outputPriority MEDIUM 40
- TI-2026-71475 Permissive regular expression in GitLab lets attackers poison cached filesPriority LOW 38
Timeline
- 2026-10-13 Threatist record created from CVE-2026-103549
- 2026-10-13 Alias added: GHSA-mqc6-5cm6-j5mh
- 2026-10-15 CISA SSVC decision points changed
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-103549 · CVE Program
- CVE-2026-103549 · NVD
- FIRST EPSS
- GHSA-mqc6-5cm6-j5mh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences