Integer overflow in Adobe CAI Content Credentials causes crashes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
Adobe's Content Credentials Rust SDK up to and including c2pa-v0.90.15, C2PA Tool up to and including c2patool-v0.27.15, and Content Credentials JS SDK up to and including @contentauth/[email protected] contain an integer overflow or wraparound (CWE-190). A remote attacker who needs no privileges or user interaction can crash the application, causing a denial of service.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
CAI Content Credentials is affected by an Integer Overflow or Wraparound vulnerability that could result in an application denial-of-service. An attacker could exploit this vulnerability to crash the application, leading to a denial-of-service condition. Exploitation of this issue does not require user interaction.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Content Credentials Rust SDK | up to c2pa-v0.90.15 | c2pa-v0.91.1 | Patch available | CNA |
| Adobe | C2PA Tool | up to c2patool-v0.27.15 | v0.28.1 | Patch available | CNA |
| Adobe | Content Credentials JS SDK | up to @contentauth/[email protected] | @contentauth/[email protected] | Patch available | CNA |
- Content Credentials Rust SDK VendorAdobe Affected up to c2pa-v0.90.15 Fixed in c2pa-v0.91.1 Patch available CNA
- C2PA Tool VendorAdobe Affected up to c2patool-v0.27.15 Fixed in v0.28.1 Patch available CNA
- Content Credentials JS SDK VendorAdobe Affected up to @contentauth/[email protected] Fixed in @contentauth/[email protected] Patch available CNA
Remediation
Upgrade Content Credentials Rust SDK to c2pa-v0.91.1, C2PA Tool to v0.28.1, and Content Credentials JS SDK to @contentauth/[email protected].
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Content Credentials Rust SDK (Adobe) Fixed in c2pa-v0.91.1
- Fix · CNA C2PA Tool (Adobe) Fixed in v0.28.1
- Fix · CNA Content Credentials JS SDK (Adobe) Fixed in @contentauth/[email protected]
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe C2PA Tool, Content Credentials JS SDK, Content Credentials Rust SDK — adobe.com/trust/security/products/content-credentials-sdk/a…
32 records Highest priority Priority MEDIUM 11 MEDIUM, 21 LOW
Other records, highest priority first
- TI-2026-73741 Server-side request forgery in Adobe CAI Content CredentialsPriority MEDIUM 46
- TI-2026-73692 Uncontrolled resource consumption in Adobe CAI Content CredentialsPriority MEDIUM 40
- TI-2026-73691 Uncontrolled resource consumption in Adobe CAI Content CredentialsPriority MEDIUM 40
Timeline
- 2026-10-13 Threatist record created from CVE-2026-100136
- 2026-10-14 Alias added: GHSA-h4f4-xvfc-627f
- 2026-10-14 Priority changed: MEDIUM → LOW
- 2026-10-15 CISA SSVC decision points changed
- 2026-10-15 Priority changed: LOW → MEDIUM
References
More Adobe C2pa vulnerabilities
- TI-2026-73741 Server-side request forgery in Adobe CAI Content Credentials CVSS 3.1HIGH 8.6
- TI-2026-52923 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400) CVSS 3.1HIGH 7.5
- TI-2026-50063 CAI Content Credentials | Improper Input Validation (CWE-20) CVSS 3.1HIGH 7.5
- TI-2026-50062 CAI Content Credentials | Integer Underflow (Wrap or Wraparound) (CWE-191) CVSS 3.1HIGH 7.5
- TI-2026-50009 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400) CVSS 3.1HIGH 7.5
- TI-2026-35833 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400) CVSS 3.1HIGH 7.5
Sources
- CVE-2026-100136 · CVE Program
- CVE-2026-100136 · NVD
- FIRST EPSS
- GHSA-h4f4-xvfc-627f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences