Reflected cross-site scripting in Link Whisper Free WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Link Whisper Free plugin for WordPress by Link Whisper INC is affected in versions through 0.9.7. Improper neutralization of input during web page generation lets reflected input run as script in the page (CWE-79). A remote attacker without privileges can exploit this if a user interacts with a crafted request.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Link Whisper INC Link Whisper Free link-whisper allows Reflected XSS.This issue affects Link Whisper Free: from n/a through 0.9.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Link Whisper | Link Whisper Free | up to 0.9.7 | — | No fix listed | CNA |
- Link Whisper Free VendorLink Whisper Affected up to 0.9.7 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for Link Whisper Free.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-109685
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-16 Priority changed: MEDIUM → LOW
More Link Whisper vulnerabilities
- TI-2026-01566 Link Whisper Free < 0.9.1 - Unauthenticated Settings and User Meta Update CVSS 3.1MEDIUM 6.5
- TI-2026-74745 PHP object injection in WordPress Link Whisper Free plugin CVSS 3.1CRITICAL 9.8
- TI-2026-74746 SQL injection in Link Whisper Free WordPress plugin CVSS 3.1CRITICAL 9.3
- TI-2023-25960 WordPress Link Whisper Free Plugin <= 0.6.5 is vulnerable to SQL Injection CVSS 3.1HIGH 8.5
- TI-2023-15788 WordPress Link Whisper Free plugin <= 0.6.3 - Unauthenticated Broken Access Control vulnerability CVSS 3.1MEDIUM 6.5
- TI-2026-71625 Blind SQL injection in Link Whisper Free WordPress plugin CVSS 3.1HIGH 7.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences