Read the docs
TI-2026-74824 Aliases CVE-2026-58394

OPNsense Stored XSS in Administration Settings via Certificate Description

Priority MEDIUM 57CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

OPNsense, a FreeBSD based firewall and routing platform, does not escape certificate descriptions in the SSL Certificate selector on the System Settings Administration page before rendering them. A user with the page-system-certmanager privilege can store HTML in a certificate description, and the markup runs in the browser of another user who opens System Settings Administration. This is CWE-79, and exploitation requires a privileged account and user interaction. CVSS 3.1 scores it 5.2 (MEDIUM), and CISA lists it as PoC exploitation, not automatable, with partial technical impact.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, src/www/system_advanced_admin.php reads certificate records into $a_cert but omits that array from legacy_html_escape_form_data() before rendering each certificate descr value in the SSL Certificate selector. The certificate description accepts HTML metacharacters, allowing a user with the page-system-certmanager privilege to store markup that executes when another user opens System Settings Administration. This issue is fixed in version 26.1.11.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00239 15th percentileScored 2026-11-07
Fix Fixed core (opnsense): 26.1.11

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opnsensecorebefore 26.1.1126.1.11Patch availableCNA
  • core Vendoropnsense Affected before 26.1.11 Fixed in 26.1.11 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*——opnsense
  • cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:* Versions — — ·opnsense

Remediation

Upgrade OPNsense to version 26.1.11 or later, which escapes certificate description values before rendering them.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA core (opnsense) Fixed in 26.1.11

Timeline

  1. 2026-10-16 Threatist record created from CVE-2026-58394

References

  • TI-2023-20247 A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense… CVSS 3.1CRITICAL 9.8
  • TI-2023-20243 Insecure permissions in the configuration directory (/conf/) of OPNsense Community… CVSS 3.1CRITICAL 9.8
  • TI-2023-20240 A command injection vulnerability in the component diag_backup.php of OPNsense Community… CVSS 3.1CRITICAL 9.8
  • TI-2023-11947 DECISO OPNsense 23.1 does not impose rate limits for authentication, allowing attackers… CVSS 3.1CRITICAL 9.8
  • TI-2026-74819 Path traversal in OPNsense GeoIP importer allows root code execution CVSS 3.1CRITICAL 9.9
  • TI-2023-20246 /ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and… CVSS 3.1CRITICAL 9.6
See all 54 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences