Dolibarr PHP Object Injection via jsonOrUnserialize()
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Dolibarr before 23.0.4 has a PHP object injection flaw (CWE-502) in jsonOrUnserialize() in functions.lib.php. The function calls unserialize() without class restrictions when json_decode() fails, so it accepts attacker-supplied serialized objects. An attacker who can write stored extrafields, export configurations or blocked log entries can plant serialized objects that trigger gadget chains for code execution or file manipulation. Exploitation requires high privileges and high attack complexity, and the flaw is not known to be exploited.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Dolibarr before 23.0.4 contains a PHP object injection vulnerability in jsonOrUnserialize() in functions.lib.php, which calls unserialize() without class restrictions when json_decode() fails. Attackers able to write stored extrafields, export configurations or blocked log entries can plant serialized objects that trigger gadget chains for code execution or file manipulation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Dolibarr to version 23.0.4. The sources do not list a vendor advisory for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA dolibarr (Dolibarr) Fixed in 23.0.4
Timeline
- 2026-10-16 Threatist record created from CVE-2026-110874
References
More Dolibarr vulnerabilities
- TI-2022-21049 Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API. CVSS 3.1CRITICAL 9.8
- TI-2022-03742 SQL Injection in dolibarr/dolibarr CVSS 3.1CRITICAL 9.8
- TI-2023-14191 Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an… CVSS 3.1HIGH 8.8
- TI-2018-15582 Dolibarr ERP CRM 7.0.3 Remote Code Execution via install/step1.php CVSS 4.0CRITICAL 9.3
- TI-2018-07157 SQL injection vulnerability in Dolibarr before 7.0.2 allows remote attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2019-15505 Dolibarr ERP/CRM 10.0.1 SQL Injection via elemid CVSS 4.0HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences