Stored cross-site scripting in Colibri Page Builder via comments
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Colibri Page Builder plugin for WordPress is affected by stored cross-site scripting in all versions up to and including 1.0.390 through the comment parameter. Unauthenticated attackers can inject arbitrary web scripts into pages that execute when a user accesses an injected page. The injected payload is stored through SVG elements with arbitrary data-* attributes, and colibri.js, loaded on every front-end page, passes the stored value into jQuery(), which runs it as HTML.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Colibri Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 1.0.390 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload survives storage because the widened comment allow-list permits SVG elements with arbitrary data-* attributes; execution occurs because colibri.js, enqueued globally on every front-end page, reads the stored data-target value via jQuery.data() — which HTML-entity-decodes it — and passes the resulting string directly into jQuery(), which parses a leading '<' as HTML and fires the embedded event handler.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| extendthemes | Colibri Page Builder | up to 1.0.390 | — | No fix listed | CNA |
- Colibri Page Builder Vendorextendthemes Affected up to 1.0.390 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:extendthemes:colibri_page_builder:*:*:*:*:*:*:*:* | — | — | extendthemes |
- cpe:2.3:a:extendthemes:colibri_page_builder:*:*:*:*:*:*:*:* Versions — — ·extendthemes
Remediation
The sources list no fixed version for Colibri Page Builder.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-107758
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-16 Priority changed: MEDIUM → LOW
- 2026-10-16 Alias added: GHSA-j6m3-8cm2-pm6p
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ccae5cbd-cfe6-48b3-8bcd-0b08ceb94680?source=cve
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/filters/svg-kses.php#L68
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/filters/svg-kses.php#L82
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/assets/static/colibri.js#L57
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/assets/static/colibri.js#L205
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/filters/svg-kses.php#L4
More extendthemes vulnerabilities
- TI-2025-02014 Kubio AI Page Builder <= 2.5.1 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2022-04358 Materialis Companion < 1.3.40 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-04096 Mesmerize Companion < 1.6.135 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2019-15245 Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-54440 WordPress Lead Generation Contact Widget & AI Chatbot: Chat Button, Phone Call, Telegram… CVSS 3.1HIGH 7.5
- TI-2024-22269 WordPress Teluro theme <= 1.0.31 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2026-107758 · CVE Program
- CVE-2026-107758 · NVD
- FIRST EPSS
- GHSA-j6m3-8cm2-pm6p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences