Image Hub WordPress plugin exposes API credentials in admin page HTML
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
The Image Hub plugin for WordPress by extendthemes is vulnerable in all versions up to and including 1.2.0. It prints plaintext API credentials for Giphy, Openverse, Pexels, Pixabay and Unsplash into every admin page's HTML (CWE-200). An authenticated attacker with subscriber-level access or above can read these credentials and overwrite the stored API keys, because the settings AJAX handler lacks a capability check.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Image Hub – Free Images from Unsplash, Pixabay, Pexels, Openverse & Giphy plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.2.0 via the 'image_hub_api_keys_* (6 options)' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract the plaintext API credentials for six third-party services — Giphy, Openverse (client ID and secret), Pexels, Pixabay, and Unsplash — emitted verbatim into every admin page's HTML via wp_localize_script. The leaked page HTML also contains a valid image_hub_nonce AJAX nonce, which — combined with the absence of any capability check in the image_hub_update_settings AJAX handler — allows the same Subscriber-level attacker to overwrite all six stored API credential options via update_option().
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| extendthemes | Image Hub – Free Images from Unsplash, Pixabay, Pexels, Openverse & Giphy | up to 1.2.0 | — | No fix listed | CNA |
- Image Hub – Free Images from Unsplash, Pixabay, Pexels, Openverse & Giphy Vendorextendthemes Affected up to 1.2.0 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for Image Hub (Free Images from Unsplash, Pixabay, Pexels, Openverse & Giphy).
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-109191
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-16 Alias added: GHSA-q237-9jp4-9hhv
References
Other 9
- https://www.wordfence.com/threat-intel/vulnerabilities/id/99d1e0cc-1fd0-47f7-8b73-33663ed72eea?source=cve
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/inc/src/MediaModal.php#L38
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/inc/src/MediaModal.php#L19
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/inc/src/Settings.php#L78
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/image-hub.php#L46
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/inc/src/Settings.php#L23
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/inc/src/MediaModal.php#L56
- https://plugins.trac.wordpress.org/browser/image-hub/tags/1.2.0/inc/src/Utils.php#L11
- https://plugins.trac.wordpress.org/changeset/3745452/image-hub/trunk/inc/src/MediaModal.php
More extendthemes vulnerabilities
- TI-2025-02014 Kubio AI Page Builder <= 2.5.1 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2022-04358 Materialis Companion < 1.3.40 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-04096 Mesmerize Companion < 1.6.135 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2019-15245 Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-54440 WordPress Lead Generation Contact Widget & AI Chatbot: Chat Button, Phone Call, Telegram… CVSS 3.1HIGH 7.5
- TI-2024-22269 WordPress Teluro theme <= 1.0.31 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2026-109191 · CVE Program
- CVE-2026-109191 · NVD
- FIRST EPSS
- GHSA-q237-9jp4-9hhv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences