PHP object injection in Gravity Forms WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Gravity Forms by Rocketgenius, Inc, a WordPress plugin, is affected from n/a before 3.1.1. Deserialization of untrusted data allows PHP object injection (CWE-502). An unauthenticated remote attacker can exploit this flaw with high attack complexity, which can lead to a complete loss of confidentiality, integrity and availability.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Deserialization of Untrusted Data vulnerability in Rocketgenius, Inc Gravity Forms gravityforms allows Object Injection.This issue affects Gravity Forms: from n/a before 3.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| RocketGenius | Gravity Forms | before 3.1.1 | 3.1.1 | Patch available | CNA |
- Gravity Forms VendorRocketGenius Affected before 3.1.1 Fixed in 3.1.1 Patch available CNA
Remediation
Update Gravity Forms to version 3.1.1 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Gravity Forms (Rocketgenius, Inc) Fixed in 3.1.1
Timeline
- 2026-10-16 Threatist record created from CVE-2026-97296
- 2026-10-16 Alias added: GHSA-vr5m-98rv-h768
More RocketGenius vulnerabilities
- TI-2026-03483 Gravity SMTP <= 2.1.4 - Unauthenticated Sensitive Information Exposure via REST API CVSS 3.1HIGH 7.5
- TI-2026-36130 WordPress Gravity Forms plugin <= 2.10.0.1 - Arbitrary File Deletion vulnerability CVSS 3.1CRITICAL 9.6
- TI-2023-13292 WordPress Gravity Forms Plugin <= 2.7.3 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2020-10759 common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed… CVSS 3.1HIGH 7.5
- TI-2026-03610 Gravity SMTP <= 2.1.4 - Missing Authorization to Authenticated (Subscriber+) Plugin Uninstall CVSS 3.1HIGH 7.1
- TI-2020-16921 A stored Cross-Site Scripting (XSS) vulnerability in the survey feature in Rocketgenius… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-97296 · CVE Program
- CVE-2026-97296 · NVD
- FIRST EPSS
- GHSA-vr5m-98rv-h768 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences