Stored cross-site scripting in SureCart plugin for WordPress
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The SureCart ecommerce plugin for WordPress is affected in all versions up to and including 4.9.4. Insufficient input sanitization and output escaping of the comment parameter (CWE-79) lets unauthenticated attackers store arbitrary web scripts in comments. The scripts run when a user opens an affected page, but only if the comment appears on a post that loads the surecart-components runtime, such as through a [sc_buy_button] shortcode, and that post contains no sc-checkout element.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.9.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful execution requires the affected comment to appear on a post that loads the surecart-components runtime (e.g. via a [sc_buy_button] shortcode) and contains no sc-checkout element, as these conditions trigger the innerHTML sink in sc-cart-loader.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SureCart | SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments | up to 4.9.4 | — | No fix listed | CNA |
- SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments VendorSureCart Affected up to 4.9.4 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for SureCart (Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments).
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-109224
- 2026-10-16 Alias added: GHSA-ppfv-pcr2-7cv3
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4aa247ff-fbc3-48e3-8e90-e3f8cdf5d97f?source=cve
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.4/dist/components/esm/sc-cart-loader.entry.js#L33
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.4/app/src/BlockLibrary/BlockServiceProvider.php#L152
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.4/app/src/BlockLibrary/BlockServiceProvider.php#L100
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.4/app/src/Support/kses.json#L216
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3742278%40surecart&new=3742278%40surecart
More SureCart vulnerabilities
- TI-2026-06737 SureCart <= 4.2.3 - Unauthenticated Linked WordPress Account Takeover via Forged customer.updated Webhook CVSS 3.1HIGH 8.1
- TI-2026-84147 Improper authentication in SureCart – Ecommerce Made Easy For Selling Physical Products… CVSS 3.1HIGH 8.1
- TI-2026-63986 WordPress SureCart plugin <= 4.7.2 - Privilege Escalation vulnerability CVSS 3.1HIGH 7.2
- TI-2026-83482 Stored cross-site scripting in SureCart WordPress plugin CVSS 3.1HIGH 7.2
- TI-2026-41251 WordPress SureCart plugin <= 4.3.2 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-29559 WordPress SureCart plugin <= 2.29.3 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2026-109224 · CVE Program
- CVE-2026-109224 · NVD
- FIRST EPSS
- GHSA-ppfv-pcr2-7cv3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences