Stored cross-site scripting in SureCart WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
SureCart, a WordPress ecommerce plugin, is affected through version 4.9.4. Insufficient input sanitization and output escaping (CWE-79) let an unauthenticated attacker store arbitrary web scripts in a comment. The script runs when a user opens a page that loads SureCart's web-component bundle and shows the comment, after the comment is auto-approved or approved by a moderator.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
The SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.9.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful execution requires the injected comment to be visible on a page that loads SureCart's web-component bundle (e.g. a page containing a SureCart Buy Button block), and the comment must be auto-approved or approved by a moderator.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SureCart | SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments | up to 4.9.4 | — | No fix listed | CNA |
- SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments VendorSureCart Affected up to 4.9.4 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for SureCart (all versions through 4.9.4).
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Timeline
- 2026-10-31 Threatist record created from CVE-2026-107653
- 2026-10-31 Alias added: GHSA-phr2-h83q-x5jf
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-01 CISA SSVC decision points changed
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2329870b-3285-4fb2-92d1-8107eb101dff?source=cve
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.2/app/src/BlockLibrary/BlockServiceProvider.php#L152
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.2/app/src/BlockLibrary/BlockServiceProvider.php#L100
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.2/app/src/Support/kses.json#L1263
- https://plugins.trac.wordpress.org/browser/surecart/tags/4.9.2/dist/components/collection/components/controllers/confirmation/manual-instructions/sc-order-manual-instructions.js
- https://plugins.trac.wordpress.org/changeset/3742278/surecart/trunk/app/src/BlockLibrary/BlockServiceProvider.php
More SureCart vulnerabilities
- TI-2026-06737 SureCart <= 4.2.3 - Unauthenticated Linked WordPress Account Takeover via Forged customer.updated Webhook CVSS 3.1HIGH 8.1
- TI-2026-84147 Improper authentication in SureCart – Ecommerce Made Easy For Selling Physical Products… CVSS 3.1HIGH 8.1
- TI-2026-63986 WordPress SureCart plugin <= 4.7.2 - Privilege Escalation vulnerability CVSS 3.1HIGH 7.2
- TI-2026-75265 Stored cross-site scripting in SureCart plugin for WordPress CVSS 3.1HIGH 7.2
- TI-2026-41251 WordPress SureCart plugin <= 4.3.2 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-29559 WordPress SureCart plugin <= 2.29.3 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2026-107653 · CVE Program
- CVE-2026-107653 · NVD
- FIRST EPSS
- GHSA-phr2-h83q-x5jf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences