SQL injection in Welcart e-Commerce via wp_usces_order_old cookie
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The Welcart e-Commerce plugin for WordPress is vulnerable to SQL injection in all versions up to and including 2.12.4. Insufficient escaping of the user-supplied searchSql and searchSkuSql JSON fields in the wp_usces_order_old parameter lets authenticated attackers with editor-level access and above append additional SQL queries to existing queries, which can extract sensitive information from the database (CWE-89).
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Welcart e-Commerce plugin for WordPress is vulnerable to generic SQL Injection via the 'wp_usces_order_old (JSON fields searchSql / searchSkuSql)' parameter in all versions up to, and including, 2.12.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with editor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Welcart e-Commerce.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-18 Threatist record created from CVE-2026-107752
- 2026-10-18 Alias added: GHSA-cpx4-rgq2-9wvh
References
Other 8
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0e78b5db-3f38-4ed7-9bec-6dd55d44f04f?source=cve
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.4/classes/orderList.class.php#L622
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.4/classes/orderList.class.php#L613
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.4/classes/orderList.class.php#L473
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.4/classes/orderList.class.php#L256
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.4/classes/orderList.class.php#L776
- https://plugins.trac.wordpress.org/changeset/3743211/usc-e-shop
- https://plugins.trac.wordpress.org/changeset/3743211/usc-e-shop/trunk/classes/orderList.class.php
More uscnanbu vulnerabilities
- TI-2023-05484 Welcart e-Commerce < 2.9.5 - Subscriber+ Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2022-03880 Welcart e-Commerce < 2.8.6 - Subscriber+ PHAR Deserialisation CVSS 3.1HIGH 8.8
- TI-2022-03786 Welcart e-Commerce < 2.8.5 - Unauthenticated Arbitrary File Access CVSS 3.1HIGH 7.5
- TI-2026-84126 Cross-site scripting in Welcart e-Commerce Plugin payment error page CVSS 4.0MEDIUM 5.3
- TI-2022-03879 Welcart e-Commerce < 2.8.5 - Subscriber+ Arbitrary File Access CVSS 3.1MEDIUM 6.5
- TI-2022-03618 Welcart e-Commerce < 2.8.4 - Subscriber+ Arbitrary Shipping Method Creation/Update/Deletion CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-107752 · CVE Program
- CVE-2026-107752 · NVD
- FIRST EPSS
- GHSA-cpx4-rgq2-9wvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences