Stored cross-site scripting in Bootstrap Shortcodes plugin for WordPress
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Bootstrap Shortcodes plugin for WordPress before 3.4.6 has a stored cross-site scripting flaw (CWE-79) in the id attribute of the [bs_tcontent] shortcode. The handler emits the value into an unquoted HTML attribute, and a space in the value lets the rest of the text become extra attributes, including JavaScript event handlers. An authenticated attacker with Contributor-level access or higher can inject script that runs in the browser of a user who views the page and interacts with the injected element.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Bootstrap Shortcodes plugin for WordPress before 3.4.6 is vulnerable to stored XSS via the id attribute of the [bs_tcontent] shortcode. The bs_tcontent() shortcode handler in inc/bs_tabs.php emits the id attribute value into an unquoted HTML attribute. esc_attr() is applied, but it does not encode space characters, so a space in the supplied value terminates the attribute and any following text is parsed as additional HTML attributes, including JavaScript event handlers. This allows authenticated attackers with Contributor-level access and above to inject arbitrary web script that executes in the browser of any user who views the page and interacts with the injected element.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Bootstrap Shortcodes project | Bootstrap Shortcodes | before 3.4.6 | 3.4.6 | Patch available | CNA |
- Bootstrap Shortcodes VendorBootstrap Shortcodes project Affected before 3.4.6 Fixed in 3.4.6 Patch available CNA
Remediation
Update the Bootstrap Shortcodes plugin for WordPress to version 3.4.6, which fixes this flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Bootstrap Shortcodes (Bootstrap Shortcodes project) Fixed in 3.4.6
Timeline
- 2026-10-18 Threatist record created from CVE-2026-112111
- 2026-10-19 Alias added: GHSA-xjrv-38f5-jpr9
- 2026-10-19 CISA SSVC decision points changed
References
Patch 1
More Bootstrap Shortcodes project vulnerabilities
- TI-2022-04373 Bootstrap Shortcodes <= 3.4.0 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-112111 · CVE Program
- CVE-2026-112111 · NVD
- FIRST EPSS
- GHSA-xjrv-38f5-jpr9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences