Stored cross-site scripting in WordPress SureCart plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress SureCart plugin by Brainstorm Force, versions from n/a through 4.9.5, contains a cross-site scripting flaw (CWE-79) caused by improper neutralization of input during web page generation. Attacker-supplied script is stored and can run in the browsers of users who view the affected content. An unauthenticated remote attacker needs a user to interact with the page, and the impact can reach beyond the plugin itself, with low confidentiality, integrity and availability impact.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force SureCart surecart allows Stored XSS.This issue affects SureCart: from n/a through 4.9.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Brainstorm Force | SureCart | up to 4.9.5 | — | No fix listed | CNA |
- SureCart VendorBrainstorm Force Affected up to 4.9.5 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for SureCart.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-21 Threatist record created from CVE-2026-112221
- 2026-10-21 Alias added: GHSA-qxhf-h57v-6gc2
- 2026-10-21 CISA SSVC decision points changed
- 2026-10-21 Priority changed: MEDIUM → LOW
References
More Brainstorm Force vulnerabilities
- TI-2025-19878 WordPress SureTriggers <= 1.0.82 - Privilege Escalation Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-02708 Incorrect comparison in Brainstorm Force OttoKit: All-in-One Automation Platform CVSS 3.1HIGH 8.1
- TI-2025-05347 SureForms < 1.7.2 - Reflected XSS CVSS 3.1MEDIUM 5.8
- TI-2020-18849 Spectra < 1.15.0 - Contributor+ Stored Cross-Side Scripting CVSS 3.1MEDIUM 5.4
- TI-2025-03050 SureForms < 1.4.4 - Contributor+ Settings Update CVSS 3.1MEDIUM 4.9
- TI-2025-11950 Starter Templates <= 4.4.41 - Authenticated (Author+) Arbitrary File Upload via WXR Upload Bypass CVSS 3.1HIGH 8.8
Sources
- CVE-2026-112221 · CVE Program
- CVE-2026-112221 · NVD
- FIRST EPSS
- GHSA-qxhf-h57v-6gc2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences