Read the docs

Path traversal in Apache Pulsar exposes packages of other tenants

Priority LOW 36CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Apache Pulsar versions from 2.10.0 before 4.0.14 and from 4.1.0 before 4.2.5 are affected when using filesystem package storage. The version component of a package name is not validated, allowing path traversal into packages of other tenants or namespaces (CWE-22). An authenticated user with the packages permission on any namespace can download, overwrite or delete those packages. If authentication is disabled, any client that reaches the admin REST API can do the same.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

The Pulsar Packages Management Service can be configured to store packages on the local filesystem of the broker by using the filesystem storage provider. Package names consist of a type, tenant, namespace, name and version. Authorization of package operations is based only on the tenant and namespace, while the storage location of a package is derived from all of these components. The version component of a package name was not validated, so it could contain URL-encoded path separators and parent directory references. The filesystem storage provider resolved such a version to a location belonging to a package in a different tenant or namespace. Because that location is inside the configured storage directory, the containment check that the filesystem storage provider performs in recent releases did not prevent the access. An authenticated user who has the packages permission on any namespace could use this to download, overwrite or delete packages stored in other tenants or namespaces for which the user has no permission. Packages overwritten or deleted in this way may be used by Pulsar Functions, Sources or Sinks, so the issue can affect the integrity and availability of these components. If authentication is disabled, the operations are available to any client that can reach the broker's admin REST API. This issue only affects deployments in which package management is enabled with the broker setting enablePackagesManagement and the filesystem storage provider (FileSystemPackagesStorageProvider) is configured with the setting packagesManagementStorageProvider. Package management is disabled by default, and the default storage provider, which stores packages in Apache BookKeeper, is not affected. This issue affects Apache Pulsar versions from 2.10.0 before 4.0.14 and from 4.1.0 before 4.2.5. - 4.0.x version users should upgrade to at least 4.0.14. - 4.1.x and 4.2.x version users should upgrade to at least 4.2.5. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. The currently supported Apache Pulsar release lines are 4.0.x and 5.0.x. The supported versions schedule is available at https://pulsar.apache.org/contribute/release-policy/.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00494 42nd percentileScored 2026-11-07
Fix Fixed Apache Pulsar (Apache Software Foundation): 4.0.14, 4.2.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Pulsar2.10.0 to before 4.0.14; 4.1.0 to before 4.2.54.0.14, 4.2.5Patch availableCNA
  • Apache Pulsar VendorApache Affected 2.10.0 to before 4.0.14; 4.1.0 to before 4.2.5 Fixed in 4.0.14, 4.2.5 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*——Apache
  • cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* Versions — — ·Apache

Remediation

Upgrade Apache Pulsar 4.0.x to 4.0.14 or later, and 4.1.x and 4.2.x to 4.2.5 or later.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

  • Fix · CNA Apache Pulsar (Apache Software Foundation) Fixed in 4.0.14, 4.2.5

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Pulsar 4.0.14, 4.2.5

    14 records Highest priority Priority MEDIUM 1 MEDIUM, 13 LOW

    Other records, highest priority first

    • TI-2026-78917 Apache Pulsar accepts unverified token roles on anonymous requestsPriority MEDIUM 41
    • TI-2026-78944 Apache Pulsar shadow topics lack authorization on source topicsPriority LOW 39
    • TI-2026-78946 Apache Pulsar proxy flaw lets forwarded users escalate privilegesPriority LOW 36

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-21 Threatist record created from CVE-2026-105945
  2. 2026-10-21 Alias added: GHSA-56rw-r678-mmwc
  3. 2026-10-23 Priority changed: MEDIUM → LOW
  4. 2026-10-24 CISA SSVC decision points changed
  5. 2026-11-06 Affected versions changed · Red Hat
  6. 2026-11-06 CVSS score added · Red Hat

References

  • TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-18186 Apache HugeGraph-Server: Command execution in gremlin KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
See all 4053 →

Sources