Incorrect authorization in GitLab lets read_api tokens create work items
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
GitLab CE and EE from 18.2 before 19.3.6, from 19.4 before 19.4.3, and from 19.5 before 19.5.1 are affected. Due to insufficient scope enforcement on a GraphQL field (CWE-863), an authenticated user with a read_api-scoped token can retrieve a project's incoming email address and create work items, bypassing the token's restrictions. Exploitation requires certain conditions to be met.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an authenticated user with a read_api-scoped token to retrieve a project's incoming email address and create work items, bypassing the token's restrictions, due to insufficient scope enforcement on a GraphQL field.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 18.2 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 | 19.3.6, 19.4.3, 19.5.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 18.2 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 Fixed in 19.3.6, 19.4.3, 19.5.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.2.0 to before 19.3.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.2.0 to before 19.3.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 19.4.0 to before 19.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 19.4.0 to before 19.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:19.5.0:*:*:*:community:*:*:* | 19.5.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:19.5.0:*:*:*:enterprise:*:*:* | 19.5.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.2.0 to before 19.3.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.2.0 to before 19.3.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 19.4.0 to before 19.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 19.4.0 to before 19.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:19.5.0:*:*:*:community:*:*:* Versions 19.5.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:19.5.0:*:*:*:enterprise:*:*:* Versions 19.5.0 Vulnerable ·GitLab
Remediation
Upgrade GitLab to 19.3.6, 19.4.3, or 19.5.1. The sources do not list a vendor advisory identifier for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA GitLab (GitLab) Fixed in 19.3.6, 19.4.3, 19.5.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.3.6, 19.4.3, 19.5.1
11 records Highest priority Priority LOW 11 LOW
Other records, highest priority first
- TI-2026-79058 LDAP injection in GitLab lets users take over LDAP-backed accountsPriority LOW 38
- TI-2026-79063 Cache poisoning in GitLab OAuth/OIDC discovery redirects flowsPriority LOW 32
- TI-2026-79059 Incorrect authorization in GitLab lets users bypass membership locksPriority LOW 31
Timeline
- 2026-10-21 Threatist record created from CVE-2026-12664
- 2026-10-22 Alias added: GHSA-g33c-grwm-jpgc
- 2026-10-23 CISA SSVC decision points changed
- 2026-10-23 Priority changed: MEDIUM → LOW
- 2026-10-23 CISA SSVC decision points changed
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-12664 · CVE Program
- CVE-2026-12664 · NVD
- FIRST EPSS
- GHSA-g33c-grwm-jpgc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences