Incorrect authorization in GitLab lets users bypass membership locks
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
GitLab EE from 12.0 before 19.3.6, from 19.4 before 19.4.3, and from 19.5 before 19.5.1 is affected. When the instance-wide SAML or LDAP membership lock was enabled, enforcement was incomplete for requests created before the lock was enabled, which is a CWE-863 incorrect authorization flaw. An authenticated user could grant or accept project and group membership outside the control of the identity provider. The public exploit is linked in the references, but the vulnerability is not listed in CISA KEV.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
GitLab has remediated an issue in GitLab EE affecting all versions from 12.0 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when the instance-wide SAML or LDAP membership lock was enabled, an authenticated user could have granted or accepted project and group membership outside the identity provider's control, due to incomplete enforcement of the membership lock on requests created before the lock was enabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.0 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 | 19.3.6, 19.4.3, 19.5.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.0 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 Fixed in 19.3.6, 19.4.3, 19.5.1 Patch available CNA
Remediation
Upgrade GitLab EE to 19.3.6, 19.4.3, or 19.5.1.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA GitLab (GitLab) Fixed in 19.3.6, 19.4.3, 19.5.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.3.6, 19.4.3, 19.5.1
11 records Highest priority Priority LOW 11 LOW
Other records, highest priority first
- TI-2026-79058 LDAP injection in GitLab lets users take over LDAP-backed accountsPriority LOW 38
- TI-2026-79063 Cache poisoning in GitLab OAuth/OIDC discovery redirects flowsPriority LOW 32
- TI-2026-79055 Incorrect authorization in GitLab lets read_api tokens create work itemsPriority LOW 32
Timeline
- 2026-10-21 Threatist record created from CVE-2026-16255
- 2026-10-22 Alias added: GHSA-m22v-48hx-jv7m
- 2026-10-23 Priority changed: MEDIUM → LOW
- 2026-10-29 CVSS score added · NVD
- 2026-10-30 CISA SSVC decision points changed
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-16255 · CVE Program
- CVE-2026-16255 · NVD
- FIRST EPSS
- GHSA-m22v-48hx-jv7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences