Incorrect Authorization in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
GitLab EE from 19.2 before 19.3.6, from 19.4 before 19.4.3, and from 19.5 before 19.5.1 has an incorrect authorization flaw (CWE-863). When an instance administrator locked a group's Duo availability, the enforcement controls were not granular enough, so an authenticated user with group Owner permissions could re-enable AI-backed data egress to a third-party service for that group and its descendant projects. The attacker needs high privileges and a valid account, and the impact is limited to low integrity loss. The flaw is not listed in CISA KEV, and a public exploit link appears in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
GitLab has remediated an issue in GitLab EE affecting all versions from 19.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when an instance administrator locked a group's Duo availability, an authenticated user with group Owner permissions could have re-enabled AI-backed data egress to a third-party service for that group and its descendant projects, due to insufficient granularity of the admin-lock enforcement controls.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 19.2 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 | 19.3.6, 19.4.3, 19.5.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 19.2 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 Fixed in 19.3.6, 19.4.3, 19.5.1 Patch available CNA
Remediation
Upgrade GitLab EE to 19.3.6, 19.4.3, or 19.5.1, depending on the release branch in use.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA GitLab (GitLab) Fixed in 19.3.6, 19.4.3, 19.5.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 19.3.6, 19.4.3, 19.5.1
11 records Highest priority Priority LOW 11 LOW
Other records, highest priority first
- TI-2026-79058 LDAP injection in GitLab lets users take over LDAP-backed accountsPriority LOW 38
- TI-2026-79063 Cache poisoning in GitLab OAuth/OIDC discovery redirects flowsPriority LOW 32
- TI-2026-79055 Incorrect authorization in GitLab lets read_api tokens create work itemsPriority LOW 32
Timeline
- 2026-10-21 Threatist record created from CVE-2026-103515
- 2026-10-22 Alias added: GHSA-x828-vfgm-5mgh
- 2026-10-30 CISA SSVC decision points changed
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-103515 · CVE Program
- CVE-2026-103515 · NVD
- FIRST EPSS
- GHSA-x828-vfgm-5mgh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences