Read the docs

Use of less trusted source in GitLab allows paid AI feature access

Priority LOW 19CWE-348Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

GitLab EE from 17.8 before 19.3.6, from 19.4 before 19.4.3, and from 19.5 before 19.5.1 is affected. Insufficient server-side validation in billing eligibility checks can let an authenticated user access paid AI features without a valid subscription under certain conditions, tracked as CWE-348. An attacker needs a low-privileged account and can affect confidentiality and integrity only to a limited degree. The flaw is not listed in CISA KEV and no public exploit is linked.

Written with Claude Haiku 5.5 from the sources below · 2026-10-30

Description from the CNA

GitLab has remediated an issue in GitLab EE affecting all versions from 17.8 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated user to access paid AI features without a valid subscription due to insufficient server-side validation in billing eligibility checks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00126 2nd percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 19.3.6, 19.4.3, 19.5.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitLabGitLab17.8 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.119.3.6, 19.4.3, 19.5.1Patch availableCNA
  • GitLab VendorGitLab Affected 17.8 to before 19.3.6; 19.4 to before 19.4.3; 19.5 to before 19.5.1 Fixed in 19.3.6, 19.4.3, 19.5.1 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*17.8.0 to before 19.3.6; 19.4.0 to before 19.4.3VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:19.5.0:*:*:*:enterprise:*:*:*19.5.0VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.8.0 to before 19.3.6; 19.4.0 to before 19.4.3 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:19.5.0:*:*:*:enterprise:*:*:* Versions 19.5.0 Vulnerable ·GitLab

Remediation

Upgrade GitLab to the fixed version for the release branch in use: 19.3.6, 19.4.3, or 19.5.1.

Written with Claude Haiku 5.5 from the sources below · 2026-10-30

  • Fix · CNA GitLab (GitLab) Fixed in 19.3.6, 19.4.3, 19.5.1

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    GitLab 19.3.6, 19.4.3, 19.5.1

    11 records Highest priority Priority LOW 11 LOW

    Other records, highest priority first

    • TI-2026-79058 LDAP injection in GitLab lets users take over LDAP-backed accountsPriority LOW 38
    • TI-2026-79063 Cache poisoning in GitLab OAuth/OIDC discovery redirects flowsPriority LOW 32
    • TI-2026-79055 Incorrect authorization in GitLab lets read_api tokens create work itemsPriority LOW 32

Timeline

  1. 2026-10-21 Threatist record created from CVE-2026-112378
  2. 2026-10-22 Alias added: GHSA-38rf-7hwj-5rg8
  3. 2026-10-30 CISA SSVC decision points changed

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources