Stored XSS in GeoDirectory gd_map shortcode width attribute
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The GeoDirectory WordPress plugin before 2.8.194 does not sanitise and escape some of its map shortcode attributes before outputting them within a style attribute. An authenticated user with the Contributor role or above can store a script that runs in the browser of any user who views the affected content, which is cross-site scripting (CWE-79). The references link to an exploit.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The GeoDirectory WordPress plugin before 2.8.194 does not sanitise and escape some of its map shortcode attributes before outputting them within a style attribute, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks that execute in the context of any user viewing the affected content.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | GeoDirectory | before 2.8.194 | 2.8.194 | Patch available | CNA |
- GeoDirectory VendorUnknown Affected before 2.8.194 Fixed in 2.8.194 Patch available CNA
Remediation
Update GeoDirectory to version 2.8.194 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA GeoDirectory (Unknown) Fixed in 2.8.194
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GeoDirectory 2.8.194
7 records Highest priority Priority LOW 7 LOW
Other records, highest priority first
- TI-2026-80043 Code injection in GeoDirectory WordPress plugin lets admins run codePriority LOW 35
- TI-2026-80041 Unauthenticated disclosure of non-public listings in GeoDirectoryPriority LOW 30
- TI-2026-80039 GeoDirectory plugin leaks non-public listings to unauthenticated usersPriority LOW 30
Timeline
- 2026-10-24 Threatist record created from CVE-2026-113493
- 2026-10-24 Alias added: GHSA-47rj-2gqg-xch4
- 2026-10-24 CVSS score added · CISA ADP
- 2026-10-24 Weakness changed · CISA ADP
- 2026-10-24 CISA SSVC decision points changed
References
Sources
- CVE-2026-113493 · CVE Program
- CVE-2026-113493 · NVD
- FIRST EPSS
- GHSA-47rj-2gqg-xch4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences