Code injection in GeoDirectory WordPress plugin lets admins run code
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-94.
Summary
The GeoDirectory WordPress plugin before 2.8.194 does not escape administrator-defined text before writing it into a generated PHP file (CWE-94). A high-privilege user, such as a subsite administrator on a multisite network, can use this to run code on the server, and any unauthenticated visitor can then trigger it. The references include a link to a public exploit.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The GeoDirectory WordPress plugin before 2.8.194 does not properly escape administrator-defined text before writing it into a generated PHP file in its own folder, allowing high privilege users such as a subsite administrator on a multisite network, who cannot otherwise run code, to achieve Remote Code Execution that any unauthenticated visitor can trigger.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | GeoDirectory | before 2.8.194 | 2.8.194 | Patch available | CNA |
- GeoDirectory VendorUnknown Affected before 2.8.194 Fixed in 2.8.194 Patch available CNA
Remediation
Update GeoDirectory to version 2.8.194, which is the first fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA GeoDirectory (Unknown) Fixed in 2.8.194
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GeoDirectory 2.8.194
7 records Highest priority Priority LOW 7 LOW
Other records, highest priority first
- TI-2026-80042 Stored XSS in GeoDirectory gd_map shortcode width attributePriority LOW 32
- TI-2026-80041 Unauthenticated disclosure of non-public listings in GeoDirectoryPriority LOW 30
- TI-2026-80039 GeoDirectory plugin leaks non-public listings to unauthenticated usersPriority LOW 30
Timeline
- 2026-10-24 Threatist record created from CVE-2026-113673
- 2026-10-24 Alias added: GHSA-qmfj-rv52-jh27
- 2026-10-24 CVSS score added · CISA ADP
- 2026-10-24 Weakness changed · CISA ADP
- 2026-10-24 CISA SSVC decision points changed
References
Sources
- CVE-2026-113673 · CVE Program
- CVE-2026-113673 · NVD
- FIRST EPSS
- GHSA-qmfj-rv52-jh27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences