Authentication bypass in Parse Server via AuthAdapter subclasses
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
Parse Server before 8.6.102 and from 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass (CWE-287) because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters that subclass AuthAdapter are never called. The inherited default accepts any authData instead. An unauthenticated remote attacker can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custom additional authentication factors.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is used instead. Attackers can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custom additional authentication factors.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 9.0.0 to before 9.10.5-alpha.2 | 9.10.5-alpha.2 | Patch available | CNA |
| parse-community | parse-server | before 8.6.102 | 8.6.102 | Patch available | CNA |
- parse-server Vendorparse-community Affected 9.0.0 to before 9.10.5-alpha.2 Fixed in 9.10.5-alpha.2 Patch available CNA
- parse-server Vendorparse-community Affected before 8.6.102 Fixed in 8.6.102 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* | — | — | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* Versions — — ·parse-community
Remediation
Upgrade parse-server to version 8.6.102 for the 8.x line or to version 9.10.5-alpha.2 for the 9.x line.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA parse-server (parse-community) Fixed in 9.10.5-alpha.2
- Fix · CNA parse-server (parse-community) Fixed in 8.6.102
Timeline
- 2026-10-25 Threatist record created from CVE-2026-116163
- 2026-10-26 CISA SSVC decision points changed
- 2026-10-26 Priority changed: MEDIUM → LOW
- 2026-10-26 Priority changed: LOW → MEDIUM
- 2026-10-27 Alias added: GHSA-f559-fhp5-c24h
References
More parse-community vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2025-35510 parse is a package designed to parse JavaScript SDK. CVSS 3.1MEDIUM 6.5
- TI-2024-26265 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-116163 · CVE Program
- CVE-2026-116163 · NVD
- FIRST EPSS
- GHSA-f559-fhp5-c24h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences