Read the docs

MongoDB Shell trusts certificates from recoverable eMudhra CAs

Priority LOW 34CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Passive
Attack complexity
High
Attack requirements
Present
Impact type
Spoofing
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-295.

Summary

MongoDB Shell (mongosh) versions from 0 before 2.14.0 are affected. The Node.js runtime bundled with mongosh has a TLS root certificate store that includes recoverable eMudhra intermediate CA certificates, so mongosh trusts certificates issued under them (CWE-295). A remote attacker with no privileges who can obtain such a certificate may impersonate a server and access or alter data, but the attack has extra conditions and needs a user to interact.

Written with Claude Haiku 5.5 from the sources below · 2026-11-02

Description from the CNA

The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00144 3rd percentileScored 2026-11-07
Fix Fixed mongosh (MongoDB, Inc.): 2.14.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MongoDBmongoshbefore 2.14.02.14.0Patch availableCNA
  • mongosh VendorMongoDB Affected before 2.14.0 Fixed in 2.14.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:mongodb:mongosh:*:*:*:*:*:*:*:*——MongoDB
  • cpe:2.3:a:mongodb:mongosh:*:*:*:*:*:*:*:* Versions — — ·MongoDB

Remediation

Update mongosh to version 2.14.0, which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime on the host, so update that runtime separately.

Written with Claude Haiku 5.5 from the sources below · 2026-11-02

  • Fix · CNA mongosh (MongoDB, Inc.) Fixed in 2.14.0

Timeline

  1. 2026-10-26 Threatist record created from CVE-2026-115930
  2. 2026-10-27 Alias added: GHSA-j35w-3h5p-45x6
  3. 2026-10-27 Priority changed: MEDIUM → LOW
  4. 2026-11-02 CISA SSVC decision points changed

References

  • TI-2019-08023 Code injection in mongo-express KEVCVSS 3.1CRITICAL 9.9
  • TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
  • TI-2026-79432 BSON output corruption via out-of-range binary subtype in MongoDB C# Driver CVSS 4.0MEDIUM 6.9
  • TI-2026-79424 NoSQL command injection via mismatched BSON length in MongoDB C# Driver CVSS 4.0MEDIUM 6.9
  • TI-2026-79422 Unbounded memory growth in MongoDB C# Driver BSON deserialization CVSS 4.0HIGH 8.2
  • TI-2026-79427 Authentication bypass via issuer-and-serial-only certificate equality CVSS 4.0HIGH 7.6
See all 376 →

Sources