Command injection in Apache Airflow SSH provider environment values
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-78.
Summary
Apache Airflow SSH provider (apache-airflow-providers-ssh) from 4.3.0 before 7.0.1 is affected. SSHRemoteJobOperator quotes the values of its templated environment parameter only once, although they sit inside an already-quoted wrapper script, so shell syntax in a value runs on the remote SSH host (CWE-78). A user who can trigger a Dag but cannot author Dags can run arbitrary commands on the remote host as the SSH connection's user when the Dag passes trigger-time input such as params or dag_run.conf into environment.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
In apache-airflow-providers-ssh before 7.0.1, SSHRemoteJobOperator quoted the values of its templated `environment` parameter only once, although they are placed inside an already-quoted wrapper script, so shell syntax such as `$(...)` in a value was executed on the remote SSH host. In a Dag that passes trigger-time input such as `params` or `dag_run.conf` into `environment`, a user who can trigger that Dag but cannot author Dags could run arbitrary commands on the remote host as the SSH connection's user. Users are advised to upgrade apache-airflow-providers-ssh to 7.0.1 or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade apache-airflow-providers-ssh to 7.0.1 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA Apache Airflow SSH provider (Apache Software Foundation) Fixed in 7.0.1
Timeline
- 2026-10-26 Threatist record created from CVE-2026-111422
- 2026-10-27 Alias added: GHSA-v5m9-m7pg-q8f3
- 2026-10-29 CISA SSVC decision points changed
- 2026-10-29 CVSS score added · CISA ADP
- 2026-10-29 CISA SSVC decision points changed
- 2026-10-29 Priority changed: LOW → MEDIUM
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More Apache vulnerabilities
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
- TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2024-18186 Apache HugeGraph-Server: Command execution in gremlin KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
Sources
- CVE-2026-111422 · CVE Program
- CVE-2026-111422 · NVD
- FIRST EPSS
- GHSA-v5m9-m7pg-q8f3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences