Stored cross-site scripting in Multiple Pages Generator by Themeisle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Multiple Pages Generator by Themeisle before 4.2.5 contains a stored cross-site scripting flaw (CWE-79) in the base-url attribute of its [mpg] and [mpg_match] shortcodes. A contributor-level user can store input that passes sanitization and runs script in administrators' browsers.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Multiple Pages Generator by Themeisle before 4.2.5 contains a stored cross-site scripting vulnerability that allows Contributor-level users to inject script via the [mpg] and [mpg_match] shortcode base-url attribute. Attackers can store entity-encoded payloads that pass kses but are decoded by html_entity_decode() and rendered unescaped through {{mpg_url}}, executing script in administrators' browsers.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
The fix is in Multiple Pages Generator by Themeisle version 4.2.5.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Multiple Pages Generator by Themeisle (Themeisle) Fixed in 4.2.5
Timeline
- 2026-10-29 Threatist record created from CVE-2026-119054
- 2026-10-29 Alias added: GHSA-pvqw-5gv9-r38m
References
Other 4
- https://plugins.svn.wordpress.org/multiple-pages-generator-by-porthas/tags/4.2.4/controllers/display/loop/Core.php
- https://plugins.svn.wordpress.org/multiple-pages-generator-by-porthas/tags/4.2.4/controllers/display/Base_Display.php
- https://plugins.svn.wordpress.org/multiple-pages-generator-by-porthas/tags/4.2.4/models/CoreModel.php
- WordPress Plugin Page
More themeisle vulnerabilities
- TI-2017-14315 WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API CVSS 4.0CRITICAL 9.3
- TI-2023-02146 Otter - Gutenberg Blocks < 2.2.6 - Author+ PHAR Deserialization CVSS 3.1HIGH 8.8
- TI-2023-20819 WordPress Redirection for Contact Form 7 plugin <= 2.9.2 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
- TI-2019-12631 A blind SSRF vulnerability exists in the Visualizer plugin before 3.3.1 for WordPress via… CVSS 3.1CRITICAL 10.0
- TI-2023-02115 Product Addons & Fields for WooCommerce < 32.0.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-04265 RSS Aggregator by Feedzy < 4.1.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-119054 · CVE Program
- CVE-2026-119054 · NVD
- FIRST EPSS
- GHSA-pvqw-5gv9-r38m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences