Authorization flaw in Parse Server misdirects installation updates
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw (CWE-639) that applies _Installation updates addressed by object ID to the installation named in the X-Parse-Installation-Id header. When protectedFieldsTriggerExempt is enabled, a remote attacker who knows another installation's object ID can make a beforeSave trigger process that installation's protected fields while writing to a different installation.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw that applies _Installation updates addressed by object ID to the installation named in the X-Parse-Installation-Id header. When protectedFieldsTriggerExempt is enabled, attackers knowing another installation's object ID can make a beforeSave trigger process that installation's protected fields while writing elsewhere.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 9.7.0 to before 9.10.5-alpha.10 | 9.10.5-alpha.10 | Patch available | CNA |
- parse-server Vendorparse-community Affected 9.7.0 to before 9.10.5-alpha.10 Fixed in 9.10.5-alpha.10 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* | — | — | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* Versions — — ·parse-community
Remediation
Upgrade parse-server to 9.10.5-alpha.10 or later, which is the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA parse-server (parse-community) Fixed in 9.10.5-alpha.10
Timeline
- 2026-10-30 Threatist record created from CVE-2026-119571
- 2026-10-30 Alias added: GHSA-74ch-jc8r-c94c
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-04 CISA SSVC decision points changed
References
More parse-community vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2025-35510 parse is a package designed to parse JavaScript SDK. CVSS 3.1MEDIUM 6.5
- TI-2024-26265 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-119571 · CVE Program
- CVE-2026-119571 · NVD
- FIRST EPSS
- GHSA-74ch-jc8r-c94c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences