Spectra Gutenberg Blocks lets unauthenticated users delete theme files
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Spectra Legacy, Gutenberg Blocks by brainstormforce is affected in all versions up to and including 2.20.4. Insufficient file path validation in the __construct function lets unauthenticated remote attackers delete theme files on the server (CWE-862).
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Description from the CNA
The Spectra Gutenberg Blocks – Website Builder for the Block Editor plugin for WordPress is vulnerable to limited file deletion due to insufficient file path validation in the '__construct' function in all versions up to, and including, 2.20.4 This makes it possible for unauthenticated attackers to delete theme files on the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Brainstorm Force | Spectra Legacy – Gutenberg Blocks | up to 2.20.4 | — | No fix listed | CNA |
- Spectra Legacy – Gutenberg Blocks VendorBrainstorm Force Affected up to 2.20.4 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for Spectra Legacy, Gutenberg Blocks.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Timeline
- 2026-10-31 Threatist record created from CVE-2026-92294
- 2026-10-31 Alias added: GHSA-2mm6-8x3p-cx55
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-03 CISA SSVC decision points changed
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/60ad515a-3c0b-47f5-919b-0d17f693c049?source=cve
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-fse-fonts-compatibility.php#L101
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-fse-fonts-compatibility.php#L93
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-fse-fonts-compatibility.php#L584
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-loader.php#L302
- https://plugins.trac.wordpress.org/changeset/3736176/
More Brainstorm Force vulnerabilities
- TI-2025-19878 WordPress SureTriggers <= 1.0.82 - Privilege Escalation Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-02708 Incorrect comparison in Brainstorm Force OttoKit: All-in-One Automation Platform CVSS 3.1HIGH 8.1
- TI-2025-05347 SureForms < 1.7.2 - Reflected XSS CVSS 3.1MEDIUM 5.8
- TI-2020-18849 Spectra < 1.15.0 - Contributor+ Stored Cross-Side Scripting CVSS 3.1MEDIUM 5.4
- TI-2025-03050 SureForms < 1.4.4 - Contributor+ Settings Update CVSS 3.1MEDIUM 4.9
- TI-2025-11950 Starter Templates <= 4.4.41 - Authenticated (Author+) Arbitrary File Upload via WXR Upload Bypass CVSS 3.1HIGH 8.8
Sources
- CVE-2026-92294 · CVE Program
- CVE-2026-92294 · NVD
- FIRST EPSS
- GHSA-2mm6-8x3p-cx55 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences