Stored cross-site scripting in Welcart e-Commerce WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Welcart e-Commerce plugin for WordPress is affected in all versions up to and including 2.12.5. Insufficient input sanitization and output escaping of the 'gid' parameter lets stored script content persist (CWE-79). An unauthenticated attacker can forge a ROBOT PAYMENT browser-return request that stores a malicious gid value in order metadata. The script runs when an administrator opens that order in the WordPress admin panel.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
The Welcart e-Commerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'gid' parameter in all versions up to, and including, 2.12.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is staged by an unauthenticated visitor who forges the ROBOT PAYMENT browser-return request, storing the malicious gid value in order metadata; the script then fires when an administrator opens that order in the WordPress admin panel.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Welcart e-Commerce.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Timeline
- 2026-10-31 Threatist record created from CVE-2026-118070
- 2026-10-31 Alias added: GHSA-8pvj-wmxx-5r34
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-01 CISA SSVC decision points changed
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/97e73872-bd1a-4b3a-9021-d0cd648456eb?source=cve
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.5/functions/template_func.php#L3279
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.5/classes/paymentJPayment.class.php#L556
- https://plugins.trac.wordpress.org/browser/usc-e-shop/tags/2.12.5/functions/utility.php#L1553
- https://plugins.trac.wordpress.org/changeset/3760784/usc-e-shop
- https://plugins.trac.wordpress.org/changeset/3760784/usc-e-shop/trunk/functions/template_func.php
More uscnanbu vulnerabilities
- TI-2023-05484 Welcart e-Commerce < 2.9.5 - Subscriber+ Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2022-03880 Welcart e-Commerce < 2.8.6 - Subscriber+ PHAR Deserialisation CVSS 3.1HIGH 8.8
- TI-2022-03786 Welcart e-Commerce < 2.8.5 - Unauthenticated Arbitrary File Access CVSS 3.1HIGH 7.5
- TI-2026-84126 Cross-site scripting in Welcart e-Commerce Plugin payment error page CVSS 4.0MEDIUM 5.3
- TI-2022-03879 Welcart e-Commerce < 2.8.5 - Subscriber+ Arbitrary File Access CVSS 3.1MEDIUM 6.5
- TI-2022-03618 Welcart e-Commerce < 2.8.4 - Subscriber+ Arbitrary Shipping Method Creation/Update/Deletion CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-118070 · CVE Program
- CVE-2026-118070 · NVD
- FIRST EPSS
- GHSA-8pvj-wmxx-5r34 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences