Read the docs

Apache Syncope lets users escalate privileges via AuthProfile updates

Priority MEDIUM 41CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.

Summary

Apache Syncope from 3.0.12 through 3.0.16, from 4.0.0-M0 through 4.0.8, and from 4.1.0-M0 through 4.1.3 is affected. AuthProfile self-updates let non-admin users configure impersonation for WA surrogate authentication, an improper privilege management flaw (CWE-269). A remote user with low privileges and an account can exploit this without user interaction.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

Improper Privilege Management vulnerability in Apache Syncope. AuthProfile self-updates allow non-admin users to configure impersonation for WA surrogate authentication. This issue affects Apache Syncope: from 3.0.12 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00489 42nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Syncope3.0.12 – 3.0.16; 4.0.0-M0 – 4.0.8; 4.1.0-M0 – 4.1.3—No fix listedCNA
  • Apache Syncope VendorApache Affected 3.0.12 – 3.0.16; 4.0.0-M0 – 4.0.8; 4.1.0-M0 – 4.1.3 Fixed in — No fix listed CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*——Apache
  • cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:* Versions — — ·Apache

Remediation

Upgrade to 4.0.9 or 4.1.4, which fix this issue. No fixed version is listed for the 3.0.12 through 3.0.16 range.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Timeline

  1. 2026-11-02 Threatist record created from CVE-2026-110535
  2. 2026-11-02 Alias added: GHSA-4mxc-3jg8-grfh
  3. 2026-11-06 CVSS score added · CISA ADP
  4. 2026-11-06 CISA SSVC decision points changed
  5. 2026-11-06 Priority changed: LOW → MEDIUM

References

  • TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-18186 Apache HugeGraph-Server: Command execution in gremlin KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
See all 4053 →

Sources