Stack buffer overflow in psqlODBC ODBC escape parser
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-121 and the CVSS impact.
Summary
PostgreSQL psqlODBC before 18.00.0006 is affected. The parser for ODBC escape sequences writes argument offsets of a {fn} escape into a fixed 16-entry stack array without a bounds check, and the array is not initialized (CWE-121). An application that forwards untrusted SQL text to the driver lets an attacker corrupt its process memory.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Description from the CNA
The psqlODBC parser for ODBC escape sequences in application SQL text writes the argument offsets of a {fn} escape into a fixed 16-entry stack array without a bound and does not initialize the array. An escape with too many arguments overflows the stack, and a reference to an unsupplied argument copies arbitrary bytes into the query. The copy of a {d}, {t}, {ts}, or {escape} body also writes one byte past a 128-byte stack buffer. An application that forwards untrusted SQL text to the driver exposes its process to memory corruption. Versions before psqlODBC 18.00.0006 are affected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PostgreSQL | psqlODBC | before 18.00.0006 | 18.00.0006 | Patch available | CNA |
- psqlODBC VendorPostgreSQL Affected before 18.00.0006 Fixed in 18.00.0006 Patch available CNA
Remediation
Upgrade psqlODBC to 18.00.0006, which fixes the flaw. Red Hat Enterprise Linux 6, 7, 8, 9 and 10 are affected, and Red Hat lists no available plan for them.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
- Fix · CNA psqlODBC (PostgreSQL) Fixed in 18.00.0006
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PostgreSQL psqlODBC 18.00.0006
11 records Highest priority Priority LOW 11 LOW
Other records, highest priority first
- TI-2026-83949 Out-of-bounds access in psqlODBC via unchecked column and row numbersPriority LOW 35
- TI-2026-83947 SQL injection in psqlODBC SQLSpecialColumns table and schema namesPriority LOW 35
- TI-2026-83943 Heap buffer overflow in psqlODBC row cache on later FETCHPriority LOW 34
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux 6 | Affected | No fix yet |
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Timeline
- 2026-11-02 Threatist record created from CVE-2026-120061
- 2026-11-02 CISA SSVC decision points changed
- 2026-11-02 Priority changed: MEDIUM → LOW
- 2026-11-02 Alias added: GHSA-rwj3-5rgf-rr95
- 2026-11-03 Affected versions changed · Red Hat
- 2026-11-03 CVSS score added · Red Hat
References
More PostgreSQL vulnerabilities
- TI-2024-01491 pgjdbc SQL Injection via line comment generation CVSS 3.1CRITICAL 10.0
- TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
- TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
- TI-2022-06097 Unchecked Class Instantiation when providing Plugin Classes CVSS 3.1CRITICAL 9.8
- TI-2022-13237 SQL Injection in ResultSet.refreshRow() with malicious column names in pgjdbc CVSS 3.1HIGH 8.0
- TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
Sources
- CVE-2026-120061 · CVE Program
- CVE-2026-120061 · NVD
- FIRST EPSS
- GHSA-rwj3-5rgf-rr95 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-120061 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences