Read the docs

Field corruption in Parse Server via null dot notation keys

Priority LOW 28CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Parse Server before 8.6.111 and from 9.0.0 before 9.10.6-alpha.3 on MongoDB skips field type validation for null-valued dot notation keys. This flaw, classified as CWE-20, lets sub-documents be written beneath Pointer, Number, String, Date, or Boolean fields. Any client with write access, including unauthenticated clients where public writes are permitted, can corrupt field values, make objects unreadable through internal date fields, or break atomic operations on number fields.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

Description from the CNA

Parse Server before 8.6.111 and 9.0.0 before 9.10.6-alpha.3 on MongoDB skips field type validation for null-valued dot notation keys, allowing sub-documents to be written beneath Pointer, Number, String, Date, or Boolean fields. Any client with write access, including unauthenticated clients where public writes are permitted, can corrupt field values, make objects unreadable via internal date fields, or break atomic operations on number fields.

Why it matters now

EPSS 0.00366 30th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 9.10.6-alpha.3, 8.6.111

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-server9.0.0 to before 9.10.6-alpha.39.10.6-alpha.3Patch availableCNA
parse-communityparse-serverbefore 8.6.1118.6.111Patch availableCNA
  • parse-server Vendorparse-community Affected 9.0.0 to before 9.10.6-alpha.3 Fixed in 9.10.6-alpha.3 Patch available CNA
  • parse-server Vendorparse-community Affected before 8.6.111 Fixed in 8.6.111 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:*——parse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* Versions — — ·parse-community

Remediation

Upgrade Parse Server 8.x to version 8.6.111 or later, and upgrade 9.x to version 9.10.6-alpha.3 or later.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

  • Fix · CNA parse-server (parse-community) Fixed in 9.10.6-alpha.3
  • Fix · CNA parse-server (parse-community) Fixed in 8.6.111

Timeline

  1. 2026-11-03 Threatist record created from CVE-2026-121415
  2. 2026-11-03 Alias added: GHSA-gv55-crjh-3f3x
  3. 2026-11-05 Priority changed: MEDIUM → LOW

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2025-35510 parse is a package designed to parse JavaScript SDK. CVSS 3.1MEDIUM 6.5
  • TI-2024-26265 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability CVSS 3.1CRITICAL 9.8
See all 158 →

Sources