Missing integrity verification in HPE Networking Fabric Composer
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
HPE Networking Fabric Composer versions from 7.0.0 through 7.3.4 and version 7.4.0 are affected. A missing integrity verification flaw lets an unauthenticated remote attacker execute arbitrary code on the affected system. Exploitation requires user interaction, and the flaw is not listed in CISA KEV or linked to a public exploit in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Description from the CNA
A missing integrity verification vulnerability exists in HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated remote attacker to execute arbitrary code on the affected system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hewlett Packard Enterprise (HPE) | Fabric Composer | 7.4.0 – 7.4.0; 7.0.0 – 7.3.4 | — | No fix listed | CNA |
- Fabric Composer VendorHewlett Packard Enterprise (HPE) Affected 7.4.0 – 7.4.0; 7.0.0 – 7.3.4 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:arubanetworks:fabric_composer:*:*:*:*:*:*:*:* | — | — | Arubanetworks |
- cpe:2.3:a:arubanetworks:fabric_composer:*:*:*:*:*:*:*:* Versions — — ·Arubanetworks
Remediation
The sources list no fixed version for Fabric Composer.
Written with Claude Haiku 5.5 from the sources below · 2026-11-03
Timeline
- 2026-11-03 Threatist record created from CVE-2026-95749
- 2026-11-03 Alias added: GHSA-fwh8-g7wm-jwvw
- 2026-11-05 Priority changed: MEDIUM → LOW
References
More Hewlett Packard Enterprise (HPE) vulnerabilities
- TI-2025-25062 A remote code execution issue exists in HPE OneView. KEVCVSS 3.1CRITICAL 10.0
- TI-2017-03684 Improper privilege management in Intel Active Mangement Technology, Intel Small Business… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2024-35876 Path traversal in Hewlett Packard Enterprise (HPE) HPE Insight Remote Support CVSS 3.1CRITICAL 9.8
- TI-2020-05748 A security vulnerability in HPE Smart Update Manager (SUM) prior to version 8.5.6 could… CVSS 3.1CRITICAL 9.8
- TI-2024-35875 XML injection in Hewlett Packard Enterprise (HPE) HPE Insight Remote Support CVSS 3.1HIGH 7.5
Sources
- CVE-2026-95749 · CVE Program
- CVE-2026-95749 · NVD
- FIRST EPSS
- GHSA-fwh8-g7wm-jwvw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences