Read the docs
TI-2026-84540 Aliases CVE-2026-95764GHSA-rgg9-94q4-r7p7

HPE Networking Fabric Composer API Improper Certificate Validation

Priority LOW 24Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

An improper certificate validation flaw in the API of HPE Networking Fabric Composer lets an unauthenticated attacker on the adjacent network access sensitive information. The CVSS 3.1 base score is 5.7 (MEDIUM), with vector CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N. Affected are Fabric Composer 7.0.0 through 7.3.4 and 7.4.0. CISA has not added it to its KEV catalog.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

Description from the CNA

An improper certificate validation vulnerability exists in the API of HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated adjacent attacker to access sensitive information.

Why it matters now

EPSS 0.00095 0th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Hewlett Packard Enterprise (HPE)Fabric Composer7.4.0 – 7.4.0; 7.0.0 – 7.3.4—No fix listedCNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:arubanetworks:fabric_composer:*:*:*:*:*:*:*:*——Arubanetworks
  • cpe:2.3:a:arubanetworks:fabric_composer:*:*:*:*:*:*:*:* Versions — — ·Arubanetworks

Remediation

The sources list no fixed version for Fabric Composer 7.0.0 through 7.3.4 or 7.4.0. Limit access to the Fabric Composer API to trusted adjacent hosts until HPE publishes a fixed release, and watch HPE's advisory for updates.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

Timeline

  1. 2026-11-03 Threatist record created from CVE-2026-95764
  2. 2026-11-03 Alias added: GHSA-rgg9-94q4-r7p7
  3. 2026-11-05 Priority changed: MEDIUM → LOW

References

  • TI-2025-25062 A remote code execution issue exists in HPE OneView. KEVCVSS 3.1CRITICAL 10.0
  • TI-2017-03684 Improper privilege management in Intel Active Mangement Technology, Intel Small Business… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2024-35876 Path traversal in Hewlett Packard Enterprise (HPE) HPE Insight Remote Support CVSS 3.1CRITICAL 9.8
  • TI-2020-05748 A security vulnerability in HPE Smart Update Manager (SUM) prior to version 8.5.6 could… CVSS 3.1CRITICAL 9.8
  • TI-2024-35875 XML injection in Hewlett Packard Enterprise (HPE) HPE Insight Remote Support CVSS 3.1HIGH 7.5
See all 927 →

Sources