Read the docs

Cross-request response header leak in FrankenPHP worker mode

Priority LOW 28CWE-488Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

FrankenPHP before 1.13.4 contains an information disclosure flaw in worker mode, where the last HTTP stream response headers are not cleared between requests (CWE-488). A later request calling http_get_last_response_headers() can read headers fetched by earlier requests on the same worker thread, exposing other users' Set-Cookie or token headers from backend APIs. An unauthenticated remote attacker can read these headers when the server handles requests in worker mode.

Written with Claude Haiku 5.5 from the sources below · 2026-11-04

Description from the CNA

FrankenPHP before 1.13.4 contains an information disclosure vulnerability in worker mode that fails to clear last HTTP stream response headers between requests, because the reset only happens in RSHUTDOWN, which worker requests skip. Later requests calling http_get_last_response_headers() can read headers fetched by earlier requests on the same worker thread, exposing other users' Set-Cookie or token headers from backend APIs.

Why it matters now

EPSS 0.00233 14th percentileScored 2026-11-07
Fix Fixed frankenphp (php): 1.13.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPfrankenphpbefore 1.13.41.13.4Patch availableCNA
  • frankenphp VendorPHP Affected before 1.13.4 Fixed in 1.13.4 Patch available CNA

Remediation

Upgrade FrankenPHP to version 1.13.4 or later.

Written with Claude Haiku 5.5 from the sources below · 2026-11-04

  • Fix · CNA frankenphp (php) Fixed in 1.13.4

Timeline

  1. 2026-11-04 Threatist record created from CVE-2026-122233
  2. 2026-11-04 Alias added: GHSA-2xgr-grwj-fv6m
  3. 2026-11-06 Priority changed: MEDIUM → LOW

References

  • TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
  • TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
See all 777 →

Sources