Priority MEDIUM 55
Improper sanitization of the value of the [srcset] attribute in <source> HTML elements in AngularJS allows attackers to bypass common image source restrictions, which can also lead to a form of Content Spoofing https://o…
CVSS 3.1MEDIUM 4.8· Network · No auth · No interaction · EPSS 0.00635 · Published 2024-09-09 · No fix listed CWE-791
Priority MEDIUM 55
Improper sanitization of the value of the 'srcset' attribute in AngularJS allows attackers to bypass common image source restrictions, which can also lead to a form of Content Spoofing https://owasp.org/www-community/att…
CVSS 3.1MEDIUM 4.8· Network · No auth · No interaction · EPSS 0.00609 · Published 2024-09-09 · No fix listed CWE-1289
Priority MEDIUM 63
Versions of the package angular from 1.2.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the angular.copy() utility function due to the usage of an insecure regular expression.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.01695 · Published 2023-03-30 · No fix listed CWE-1333
Priority MEDIUM 63
Versions of the package angular from 1.4.9 are vulnerable to Regular Expression Denial of Service (ReDoS) via the <input type="url"> element due to the usage of an insecure regular expression in the input[url] functional…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.01695 · Published 2023-03-30 · No fix listed CWE-1333
Priority MEDIUM 63
Versions of the package angular from 1.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the $resource service due to the usage of an insecure regular expression.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.01695 · Published 2023-03-30 · No fix listed CWE-1333
Priority LOW 38
All versions of the package angular; all versions of the package angularjs.core; all versions of the package angularjs are vulnerable to Cross-site Scripting (XSS) due to insecure page caching in the Internet Explorer br…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0768 · Published 2022-07-15 · No fix listed CWE-79
Priority LOW 27
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01181 · Published 2022-05-26 · Partial fix · 11.0.5, 11.1.0-next.3 +1 CWE-79
Priority MEDIUM 41
The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PA…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.04927 · Published 2022-05-01 · No fix listed CWE-1333
Priority LOW 28
angular.js prior to 1.8.0 allows cross site scripting.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01932 · Published 2020-06-08 · Partial fix · 1.8.0 CWE-79
Priority LOW 30
There is a vulnerability in all angular versions before 1.5.0-beta.0, where after escaping the context of the web application, the web application delivers data to its users along with other trusted dynamic content, with…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01198 · Published 2020-01-02 · Fixed in 1.5.0-beta.0, 1.5.0-beta.1 CWE-79
Priority LOW 37
In AngularJS before 1.7.9 the function `merge()` could be tricked into adding or modifying properties of `Object.prototype` using a `__proto__` payload.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01982 · Published 2019-11-19 · Partial fix · 1.7.9 CWE-1321