Priority MEDIUM 64
LogicalDOC Enterprise 7.7.4 contains multiple post-authentication file disclosure vulnerabilities that allow attackers to read arbitrary files through unverified 'suffix' and 'fileVersion' parameters.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.01129 · Published 2025-12-24 · No fix listed CWE-22
Priority MEDIUM 61
A vulnerability was identified in LogicalDOC Community Edition up to 9.2.1.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00791 · Published 2025-10-31 · No fix listed CWE-307
Priority MEDIUM 56
A vulnerability was determined in LogicalDOC Community Edition up to 9.2.1.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00287 · Published 2025-10-31 · No fix listed CWE-79
Priority MEDIUM 56
A security flaw has been discovered in LogicalDOC Community Edition up to 9.2.1.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00366 · Published 2025-10-19 · No fix listed CWE-79
Priority LOW 28
There is a reflected cross-site scripting (XSS) within JSP files used to control application appearance.
CVSS 4.0MEDIUM 6.4· Network · No auth · User interaction · EPSS 0.00266 · Published 2025-03-14 · No fix listed CWE-79
Priority MEDIUM 47
The API used to interact with documents in the application contains two endpoints with a flaw that allows an authenticated attacker to write a file with controlled contents to an arbitrary location on the underlying file…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00612 · Published 2025-03-14 · Fixed in 9.1 CWE-23
Priority MEDIUM 46
The Automation Scripting functionality can be exploited by attackers to run arbitrary system commands on the underlying operating system.
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.00579 · Published 2025-03-14 · Fixed in 9.1 CWE-94
Priority MEDIUM 58
LogicalDOC Enterprise and Community Edition (CE) are vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition in the document version comments.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00497 · Published 2023-02-07 · No fix listed CWE-79
Priority MEDIUM 58
LogicalDOC Enterprise and Community Edition (CE) are vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition in the document file name.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00497 · Published 2023-02-07 · No fix listed CWE-79
Priority MEDIUM 58
LogicalDOC Enterprise is vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition in the in-app chat system.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00497 · Published 2023-02-07 · No fix listed CWE-79
Priority MEDIUM 58
LogicalDOC Enterprise and Community Edition (CE) are vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition in the in-app messaging system (both subject and message bodies).
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00477 · Published 2023-02-07 · No fix listed CWE-79
Priority LOW 35
A local privilege elevation vulnerability exists in the file system permissions of LogicalDoc 8.5.1 installation.
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00611 · Published 2020-12-03 · No fix listed CWE-276
Priority LOW 36
LogicalDoc before 8.3.3 allows /servlet.gupld Directory Traversal, a different vulnerability than CVE-2020-9423 and CVE-2020-10365.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01456 · Published 2020-04-07 · No fix listed CWE-22
Priority LOW 31
LogicalDoc before 8.3.3 allows SQL Injection.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.01255 · Published 2020-03-18 · No fix listed CWE-89
Priority MEDIUM 50
LogicalDoc before 8.3.3 could allow an attacker to upload arbitrary files, leading to command execution or retrieval of data from the database.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05007 · Published 2020-03-18 · No fix listed CWE-434
Priority LOW 34
LogicalDOC Community Edition 8.x before 8.2.1 has a path traversal vulnerability that allows reading arbitrary files and the creation of directories, in the class PluginRegistry.
CVSS 3.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.01284 · Published 2019-05-30 · No fix listed CWE-22
Priority LOW 25
LogicalDoc Community Edition 7.5.3 and prior is vulnerable to an XSS when using preview on HTML document.
CVSS 3.0MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00546 · Published 2017-07-13 · No fix listed CWE-79
Priority MEDIUM 40
LogicalDoc Community Edition 7.5.3 and prior contain an Incorrect access control which could leave to privilege escalation.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01212 · Published 2017-07-13 · No fix listed CWE-732
Priority MEDIUM 40
LogicalDoc Community Edition 7.5.3 and prior is vulnerable to XXE when indexing XML documents.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01212 · Published 2017-07-13 · No fix listed CWE-611