Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

4 records

Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPDeveloper NotificationX notificationx allows Stored XSS.This issue affects NotificationX: from n/a through <= 2.9.5.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00315 Published 2025-02-03 No fix listed CWE-79
Priority CRITICAL 88

The NotificationX – Best FOMO, Social Proof, WooCommerce Sales Popup & Notification Bar Plugin With Elementor plugin for WordPress is vulnerable to SQL Injection via the 'type' parameter in all versions up to, and includ…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.77434 Published 2024-02-27 No fix listed CWE-89
Priority LOW 20

The NotificationX plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.8.2.

CVSS 3.1MEDIUM 4.3 Network No auth User interaction EPSS 0.00384 Published 2023-07-01 Fixed in 1.8.3 CWE-352
Priority HIGH 67

The NotificationX WordPress plugin before 2.3.9 does not sanitise and escape the nx_id parameter before using it in a SQL statement, leading to an Unauthenticated Blind SQL Injection

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.34359 Published 2022-03-07 Fixed in 2.3.9 CWE-89