Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

14 records

Priority LOW 22

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes.

CVSS 4.0LOW 2.1 Network High privileges No interaction EPSS 0.01158 Published 2025-04-14 Fixed in 6.1.5 CWE-613
TI-2024-16547 CVE-2024-25090 · GHSA-g9rf-qc6j-h2f7

Improper input validation in Apache Roller

Priority LOW 26

Insufficient input validation and sanitation in Profile name & screenname, Bookmark name & description and blogroll name features in all versions of Apache Roller on all platforms allows an authenticated user to perform…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00752 Published 2024-07-26 Fixed in 6.1.3 CWE-20
TI-2023-19179 CVE-2023-37581 · GHSA-mccf-357g-w594

Cross-site scripting in Apache Roller

Priority LOW 27

Insufficient input validation and sanitation in Weblog Category name, Website About and File Upload features in all versions of Apache Roller on all platforms allows an authenticated user to perform an XSS attack.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01172 Published 2023-08-06 Fixed in 6.1.2 CWE-79
TI-2021-12966 CVE-2021-33580 · GHSA-x9w7-f6x8-r9xh

regex injection leading to DoS

Priority LOW 39

User controlled `request.getHeader("Referer")`, `request.getRequestURL()` and `request.getQueryString()` are used to build and run a regex expression.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.03298 Published 2021-08-18 Fixed in 6.0.2 CWE-400
TI-2019-00207 CVE-2019-0234 · GHSA-g2p9-qx45-9p93

Cross-site scripting in Apache Roller

Priority LOW 33

A Reflected Cross-site Scripting (XSS) vulnerability exists in Apache Roller.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.03445 Published 2019-07-15 No fix listed CWE-79
TI-2018-12297 CVE-2018-17198 · GHSA-38f5-5m8x-c6h5

Server-side request forgery in Apache Roller

Priority MEDIUM 49

Server-side Request Forgery (SSRF) and File Enumeration vulnerability in Apache Roller 5.2.1, 5.2.0 and earlier unsupported versions relies on Java SAX Parser to implement its XML-RPC interface and by default that parser…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.04124 Published 2019-05-28 No fix listed CWE-918
Priority LOW 33

Multiple cross-site request forgery (CSRF) vulnerabilities in the admin/editor console in Apache Roller before 5.0.1 allow remote attackers to hijack the authentication of admins or editors by leveraging the HTTP POST fu…

CVSS 2.0MEDIUM 6.8 Network No auth Interaction — EPSS 0.01574 Published 2012-06-26 No fix listed CWE-352