Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

2 records

TI-2022-23409 CVE-2022-47318 · GHSA-pphf-gfrm-v32r

Code injection in ruby-git

Priority MEDIUM 43

ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product.

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.01422 Published 2023-01-17 Fixed in v1.13.0, 1.13.0 CWE-94
TI-2022-23055 CVE-2022-46648 · GHSA-pfpr-3463-c6jh

Code injection in ruby-git

Priority MEDIUM 40

ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product.

CVSS 3.1HIGH 8.0 Network Low privileges User interaction EPSS 0.01414 Published 2023-01-17 Fixed in v1.13.0, 1.13.0 CWE-94