Priority HIGH 70
The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized arbitrary file deletion in versions up to, and including, 0.9.0.2 due to a lack of capability checking and insufficient path validation.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01491 · Published 2024-10-16 · Fixed in 0.9.0.3 CWE-352
Priority MEDIUM 60
The WP Fastest Cache WordPress plugin before 0.9.5 is lacking a CSRF check in its wpfc_save_cdn_integration AJAX action, and does not sanitise and escape some the options available via the action, which could allow attac…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00252 · Published 2024-01-16 · Fixed in 0.9.5 CWE-352
Priority HIGH 73
The WP Fastest Cache WordPress plugin before 0.9.5 does not escape user input in the set_urls_with_terms method before using it in a SQL statement, leading to an SQL injection exploitable by low privilege users such as s…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01178 · Published 2024-01-16 · Fixed in 0.9.5 CWE-89
Priority HIGH 71
The WP Fastest Cache WordPress plugin before 1.2.2 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.73708 · Published 2023-12-04 · Fixed in 1.2.2 CWE-89
Priority LOW 21
The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized cache deletion in versions up to, and including, 1.1.2 due to a missing capability check in the deleteCacheToolbar function .
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00534 · Published 2023-06-09 · No fix listed CWE-862
Priority HIGH 73
The WP Fastest Cache WordPress plugin before 1.1.5 does not have CSRF check in an AJAX action, and does not validate user input before using it in the wp_remote_get() function, leading to a Blind SSRF issue
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.08466 · Published 2023-05-30 · Fixed in 1.1.5
Priority LOW 20
The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the wpfc_preload_single_callback function in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00386 · Published 2023-04-06 · No fix listed CWE-862
Priority LOW 20
The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the wpfc_purgecache_varnish_callback function in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00386 · Published 2023-04-06 · No fix listed CWE-862
Priority LOW 20
The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data deletion due to a missing capability check on the wpfc_clear_cache_of_allsites_callback function in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00386 · Published 2023-04-06 · No fix listed CWE-862
Priority LOW 20
The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data loss due to a missing capability check on the deleteCssAndJsCacheToolbar function in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00386 · Published 2023-04-06 · No fix listed CWE-862
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 19
The WP Fastest Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00227 · Published 2023-04-06 · No fix listed CWE-352
Priority LOW 34
Directory traversal vulnerability in WP Fastest Cache versions prior to 0.9.1.7 allows a remote attacker with administrator privileges to delete arbitrary files on the server via unspecified vectors.
CVSS 3.1MEDIUM 6.5· Network · High privileges · No interaction · EPSS 0.02625 · Published 2021-04-27 · Fixed in 0.9.1.7 CWE-22
Priority MEDIUM 47
The wp-fastest-cache plugin before 0.8.4.9 for WordPress has SQL injection in wp-admin/admin-ajax.php?action=wpfc_wppolls_ajax_request via the poll_id parameter.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02987 · Published 2019-08-14 · No fix listed CWE-89
Priority HIGH 68
The WP Fastest Cache plugin through 0.8.9.5 for WordPress allows wpFastestCache.php and inc/cache.php Directory Traversal.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.44363 · Published 2019-07-30 · No fix listed CWE-22
Priority LOW 36
The WP Fastest Cache plugin through 0.8.9.0 for WordPress allows remote attackers to delete arbitrary files because wp_postratings_clear_fastest_cache and rm_folder_recursively in wpFastestCache.php mishandle ../ in an H…
CVSS 3.0MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.04348 · Published 2019-07-29 · No fix listed CWE-22
Priority LOW 30
The WP Fastest Cache plugin 0.8.8.5 for WordPress has XSS via the rules[0][content] parameter in a wpfc_save_timeout_pages action.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01365 · Published 2019-04-15 · No fix listed CWE-79
Load more