Priority LOW 23
Bludit CMS through 3.22.0 contains an authorization bypass vulnerability that allows authenticated users with the Author role to enumerate and delete media files belonging to pages owned by other users, including adminis…
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00189 · Published 2026-09-25 · No fix listed CWE-639
Priority LOW 31
Bludit CMS through 3.22.0 contains a missing authorization vulnerability that allows authenticated users holding the Author or Editor role to read the full content of private drafts and scheduled posts belonging to any o…
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00209 · Published 2026-09-25 · No fix listed CWE-862
Priority LOW 23
Bludit CMS through 3.22.0 contains a mass assignment vulnerability that allows authenticated users with the Author role to modify privileged page fields reserved for administrators by injecting reserved parameters into a…
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00186 · Published 2026-09-25 · No fix listed CWE-915
Priority LOW 24
A stored cross-site scripting (XSS) vulnerability in Bludit 4.0.0-beta allows a low-privileged authenticated user (Author role) to inject arbitrary JavaScript by uploading a crafted SVG file as the site logo.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00289 · Published 2026-08-10 · No fix listed CWE-79
Priority MEDIUM 64
Bludit is a content management system.
CVSS 3.1HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00271 · Published 2026-06-08 · Fixed in 3.22.0 CWE-212
Priority HIGH 73
Bludit is a content management system.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00294 · Published 2026-06-08 · Fixed in 3.22.0 CWE-285
Priority MEDIUM 62
Bludit CMS prior to commit 6732dde contains a reflected cross-site scripting vulnerability in the search plugin that allows unauthenticated attackers to inject arbitrary JavaScript by crafting a malicious search query.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.03539 · Published 2026-04-21 · Fixed CWE-79
Priority LOW 22
Bludit is vulnerable to Stored Cross-Site Scripting (XSS) in its page creating functionality.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00164 · Published 2026-04-07 · No fix listed CWE-79
Priority MEDIUM 44
Bludit’s API plugin allows an authenticated attacker with a valid API token to upload files of any type and extension without restriction, which can then be executed, leading to Remote Code Execution.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.01993 · Published 2026-03-27 · Fixed in 3.18.4 CWE-434
Priority LOW 21
Bludit is vulnerable to Stored Cross-Site Scripting (XSS) in its image upload functionality.
CVSS 4.0MEDIUM 4.8· Network · Low privileges · User interaction · EPSS 0.00198 · Published 2026-03-27 · No fix listed CWE-79
Priority LOW 22
Bludit allows user's session identifier to be set before authentication.
CVSS 4.0MEDIUM 4.8· Local · No auth · User interaction · EPSS 0.0037 · Published 2026-03-27 · Fixed in 3.17.2 CWE-384
Priority MEDIUM 56
Bludit version 3.16.1 contains a cross-site request forgery (CSRF) vulnerability in the /admin/uninstall-plugin/ and /admin/install-theme/ endpoints.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00171 · Published 2026-02-23 · No fix listed CWE-352
Priority LOW 22
Bludit version 3.16.2 contains a stored cross-site scripting (XSS) vulnerability in the post content functionality.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00165 · Published 2026-02-23 · No fix listed CWE-79
Priority LOW 33
Bludit versions before 3.13.0 contain an authenticated file download vulnerability in the Backup Plugin that allows logged-in users to access arbitrary files.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00811 · Published 2025-12-17 · Fixed in 3.13.0 CWE-22
Priority LOW 26
Bludit uses predictable methods in combination with the MD5 hashing algorithm to generate sensitive tokens such as the API token and the user token.
CVSS 4.0MEDIUM 6.0· Network · Low privileges · No interaction · EPSS 0.00242 · Published 2024-06-24 · No fix listed CWE-287
Priority LOW 28
Bludit uses the SHA-1 hashing algorithm to compute password hashes.
CVSS 4.0MEDIUM 5.9· Network · High privileges · No interaction · EPSS 0.00217 · Published 2024-06-24 · No fix listed CWE-916
Priority LOW 27
A session fixation vulnerability in Bludit allows an attacker to bypass the server's authentication if they can trick an administrator or any other user into authorizing a session ID of their choosing.
CVSS 4.0MEDIUM 5.6· Network · High privileges · User interaction · EPSS 0.00392 · Published 2024-06-24 · No fix listed CWE-384
Priority HIGH 74
A security vulnerability has been identified in Bludit, allowing authenticated attackers to execute arbitrary code through the Image API.
CVSS 4.0HIGH 8.9· Network · High privileges · No interaction · EPSS 0.00755 · Published 2024-06-24 · No fix listed CWE-434
Priority HIGH 74
A security vulnerability has been identified in Bludit, allowing attackers with knowledge of the API token to upload arbitrary files through the File API which leads to arbitrary code execution on the server.
CVSS 4.0HIGH 8.9· Network · High privileges · No interaction · EPSS 0.00692 · Published 2024-06-24 · No fix listed CWE-434
Priority MEDIUM 55
Cross Site Scripting (XSS) vulnerability in Bludit CMS version 3.15, allows remote attackers to execute arbitrary code and obtain sensitive information via edit-content.php.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00566 · Published 2024-02-17 · No fix listed CWE-79
Priority MEDIUM 55
Cross Site Scripting Vulnerability in BluditCMS v.3.14.1 allows attackers to execute arbitrary code via the Categories Friendly URL.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00511 · Published 2023-09-01 · No fix listed CWE-79
Priority HIGH 69
Permissions vulnerability found in Bludit CMS v.4.0.0 allows local attackers to escalate privileges via the role:admin parameter.
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00237 · Published 2023-09-01 · No fix listed CWE-862
Priority HIGH 73
Bludit 3.9.2 is vulnerable to Remote Code Execution (RCE) via /admin/ajax/upload-images.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01263 · Published 2023-06-26 · No fix listed CWE-434
Priority LOW 26
Bludit v3.14.1 was discovered to contain an arbitrary file upload vulnerability in the component /admin/new-content.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00804 · Published 2023-06-16 · No fix listed CWE-434
Priority MEDIUM 58
Bludit v3.14.1 is vulnerable to Stored Cross Site Scripting (XSS) via SVG file on site logo.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.02586 · Published 2023-05-17 · No fix listed CWE-79
Load more