Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

96 records

Priority HIGH 72

Control Web Panel (CWP) before webpanel_version 1.29 contains an OS command injection vulnerability in the loopback API /valid_token/ route that allows unauthenticated attackers to execute arbitrary commands as root by i…

CVSS 4.0HIGH 8.5 Local Low privileges No interaction EPSS 0.01195 Published 2026-11-02 Fixed in 1.29 CWE-78
Priority LOW 29

Control Web Panel (CWP) before webpanel_version 1.29 contains a blind SQL injection vulnerability in an unauthenticated loopback API route that connects to MySQL as root, where the 'user' parameter is interpolated direct…

CVSS 4.0MEDIUM 6.8 Local Low privileges No interaction EPSS 0.00191 Published 2026-11-02 Fixed in 1.29 CWE-89
Priority LOW 38

Control Web Panel (CWP) before webpanel_version 1.16 contains an OS command injection vulnerability in the loopback API password change route /newpass/, which runs as root.

CVSS 4.0HIGH 8.5 Local Low privileges No interaction EPSS 0.00789 Published 2026-11-02 Fixed in 1.16 CWE-78
Priority HIGH 72

Control Web Panel (CWP) before webpanel_version 1.16 contains a SQL injection vulnerability in the loopback API authentication gate access_token(), which connects to MySQL as root and interpolates attacker-controlled val…

CVSS 4.0HIGH 8.4 Local Low privileges No interaction EPSS 0.00218 Published 2026-11-02 Fixed in 1.16 CWE-89
Priority MEDIUM 40

Control Web Panel (CWP) before webpanel_version 1.29 contains an OS command injection vulnerability in the loopback API database restore route /v1/restoredatabase/, where the restoreDBBackup() handler passes an attacker-…

CVSS 4.0HIGH 8.5 Local Low privileges No interaction EPSS 0.00848 Published 2026-11-02 Fixed in 1.29 CWE-78
Priority LOW 38

Control Web Panel (CWP) before webpanel_version 1.29 contains a missing authentication vulnerability that allows attackers able to reach the loopback API service to invoke root-privileged API routes without presenting an…

CVSS 4.0HIGH 8.5 Local Low privileges No interaction EPSS 0.00165 Published 2026-11-02 Fixed in 1.29 CWE-306
Priority MEDIUM 42

Control Web Panel (CWP) before webpanel_version 1.16 contains an OS command injection vulnerability in the protected_directory user panel module that allows attackers to execute arbitrary commands by submitting unescaped…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.02251 Published 2026-11-02 Fixed in 1.16 CWE-78
Priority MEDIUM 43

Control Web Panel (CWP) before webpanel_version 1.16 contains an arbitrary file write and OS command injection vulnerability in the phpini_editor user panel module that allows attackers with access to the module to write…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.01809 Published 2026-11-02 Fixed in 1.16 CWE-22
Priority MEDIUM 46

Control Web Panel (CWP) before webpanel_version 1.12 contains an execution after redirect vulnerability in the user panel authentication flow (CWPUserIndex) that allows unauthenticated attackers to bypass authentication…

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00493 Published 2026-11-02 Fixed in 1.12 CWE-698
Priority LOW 39

Control Web Panel (CWP) before webpanel_version 1.16 contains a path traversal vulnerability in services/users/index.php that allows attackers to include arbitrary local PHP files by supplying an unsanitized module name…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00952 Published 2026-11-02 Fixed in 1.16 CWE-98
Priority HIGH 81

Control Web Panel before 0.9.8.1225 contains a blind SQL injection vulnerability that allows unauthenticated remote attackers to execute arbitrary SQL queries by submitting unsanitized input through the userRes POST para…

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00963 Published 2026-07-01 Fixed in 0.9.8.1225 CWE-89
TI-2025-30935 CVE-2025-48703 · GHSA-vx2w-cj7g-8hcf

OS command injection in CentOS Web Panel

Priority CRITICAL 98KEV

CWP (aka Control Web Panel or CentOS Web Panel) before 0.9.8.1205 allows unauthenticated remote code execution via shell metacharacters in the t_total parameter in a filemanager changePerm request.

CVSS 3.1CRITICAL 9.0 Network No auth No interaction EPSS 0.99655 Published 2025-09-19 Fixed in 0.9.8.1205 CWE-78
TI-2023-22491 CVE-2023-42123 · GHSA-vj52-239v-8h2j

OS command injection in Control Web Panel

Priority MEDIUM 44

Control Web Panel mysql_manager Command Injection Remote Code Execution Vulnerability.

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.02307 Published 2024-05-03 No fix listed CWE-78
TI-2023-22490 CVE-2023-42122 · GHSA-wx6x-wf29-2wrc

OS command injection in Control Web Panel

Priority LOW 37

Control Web Panel wloggui Command Injection Local Privilege Escalation Vulnerability.

CVSS 3.0HIGH 7.8 Local Low privileges No interaction EPSS 0.00767 Published 2024-05-03 No fix listed CWE-78
TI-2023-22489 CVE-2023-42121 · GHSA-m2qh-hm8j-fx8m

Missing authentication in Control Web Panel

Priority MEDIUM 53

Control Web Panel Missing Authentication Remote Code Execution Vulnerability.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01839 Published 2024-05-03 No fix listed CWE-306
TI-2023-22488 CVE-2023-42120 · GHSA-3cxr-mgrx-fg7c

OS command injection in Control Web Panel

Priority MEDIUM 45

Control Web Panel dns_zone_editor Command Injection Remote Code Execution Vulnerability.

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.0263 Published 2024-05-03 No fix listed CWE-78
Priority CRITICAL 86

In CWP (aka Control Web Panel or CentOS Web Panel) before 0.9.8.1107, an unauthenticated attacker can use %00 bytes to cause /user/loader.php to register an arbitrary API key, as demonstrated by a /user/loader.php?api=1&…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.70745 Published 2022-12-26 No fix listed CWE-862
TI-2020-12303 CVE-2020-15628 · GHSA-whvm-7q6x-qjfp

SQL injection in CentOS Web Panel

Priority LOW 39

This vulnerability allows remote attackers to disclose sensitive information on affected installations of CentOS Web Panel cwp-e17.0.9.8.923.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0383 Published 2020-07-28 No fix listed CWE-89
Load more