Priority HIGH 77
Easy!Appointments through 1.6.0 contains an authorization bypass vulnerability in Booking::register() that allows unauthenticated attackers to modify any appointment by supplying an appointment id without its hash.
CVSS 4.0HIGH 8.8· Network · No auth · No interaction · EPSS 0.0034 · Published 2026-10-11 · No fix listed CWE-639
Priority LOW 29
The Easy Appointments plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.12.27 via the handle_customers_ajax.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00475 · Published 2026-09-19 · No fix listed CWE-862
Priority LOW 37
Plainpad through 1.1.1, fixed in commit d3823fc, contains a missing rate limiting vulnerability that allows unauthenticated attackers to send unbounded login requests to the POST /v1/sessions endpoint due to dead code in…
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00409 · Published 2026-08-18 · Fixed CWE-307
Priority LOW 37
The Easy Appointments plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check and missing nonce verification on the `ea_delete_multiple_connections` AJAX action in all ve…
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00401 · Published 2026-07-24 · No fix listed CWE-863
Priority MEDIUM 64
Easy!Appointments is a self hosted appointment scheduler.
CVSS 3.1HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00228 · Published 2026-07-14 · No fix listed CWE-200
Priority LOW 15
Easy!Appointments is a self hosted appointment scheduler.
CVSS 3.1LOW 3.1· Network · High privileges · User interaction · EPSS 0.00206 · Published 2026-07-14 · Fixed in 1.6.0 CWE-639
Priority MEDIUM 47
Easy!Appointments is a self hosted appointment scheduler.
CVSS 3.1LOW 2.7· Network · High privileges · No interaction · EPSS 0.00233 · Published 2026-07-14 · Fixed in 1.6.0 CWE-918
Priority MEDIUM 49
Easy!Appointments is a self hosted appointment scheduler.
CVSS 3.1LOW 3.3· Network · High privileges · No interaction · EPSS 0.00178 · Published 2026-07-14 · Fixed in 1.6.0 CWE-639
Priority MEDIUM 46
Easy!Appointments is a self hosted appointment scheduler.
CVSS 3.1LOW 2.6· Network · High privileges · User interaction · EPSS 0.00223 · Published 2026-07-14 · Fixed in 1.6.0 CWE-79
Priority HIGH 70
Easy!Appointments is a self hosted appointment scheduler.
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00459 · Published 2026-07-14 · Fixed in 1.6.0 CWE-200
Priority LOW 20
The Easy Appointments plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.12.27.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.0046 · Published 2026-07-10 · No fix listed CWE-862
Priority LOW 38
Plainpad is a self hosted note taking app.
CVSS 3.1HIGH 8.3· Network · Low privileges · No interaction · EPSS 0.00261 · Published 2026-05-09 · Fixed in 1.1.1 CWE-269
Priority MEDIUM 43
The Easy Appointments plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.12.21 via the `/wp-json/wp/v2/eablocks/ea_appointments/` REST API endpoint.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0239 · Published 2026-04-17 · No fix listed CWE-200
Priority HIGH 74
Easy!Appointments is a self hosted appointment scheduler.
CVSS 4.0HIGH 7.4· Network · No auth · User interaction · EPSS 0.00231 · Published 2026-01-15 · No fix listed CWE-352
Priority HIGH 74
alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00365 · Published 2025-08-25 · Fixed in 1.5.2-beta.1 CWE-89
Priority HIGH 66
Booking logic flaw in Easy!Appointments v1.5.1 allows unauthenticated attackers to create appointments with excessively long durations, causing a denial of service by blocking all future booking availability.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0059 · Published 2025-05-07 · No fix listed CWE-284
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in alextselegidis Easy!Appointments easyappointments allows Cross Site Request Forgery.This issue affects Easy!Appointments: from n/a through <= 1.4.2.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00254 · Published 2025-04-01 · No fix listed CWE-352
Priority HIGH 75
An issue in Alex Tselegidis EasyAppointments v.1.5.0 allows a remote attacker to escalate privileges via the index.php file.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00831 · Published 2025-02-12 · No fix listed CWE-269
Priority MEDIUM 60
Cross Site Scripting vulnerability in Alex Tselegidis EasyAppointments v.1.5.0 allows a remote attacker to execute arbitrary code via the legal_settings parameter.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00516 · Published 2025-02-12 · No fix listed CWE-79
Priority LOW 38
A BOLA vulnerability in POST /providers allows a low privileged user to create a privileged user (provider) in the system.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00349 · Published 2024-07-09 · Fixed CWE-639
Priority MEDIUM 43
A BOLA vulnerability in GET, PUT, DELETE /services/{serviceId} allows a low privileged user to fetch, modify or delete the services of any user (including admin).
CVSS 3.1CRITICAL 9.6· Network · Low privileges · No interaction · EPSS 0.0039 · Published 2024-07-09 · Fixed CWE-639
Priority MEDIUM 43
A BOLA vulnerability in GET, PUT, DELETE /customers/{customerId} allows a low privileged user to fetch, modify or delete a low privileged user (customer).
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.004 · Published 2024-07-09 · Fixed CWE-639
Priority MEDIUM 43
A BOLA vulnerability in GET, PUT, DELETE /settings/{settingName} allows a low privileged user to fetch, modify or delete the settings of any user (including admin).
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.004 · Published 2024-07-09 · Fixed CWE-639
Priority MEDIUM 43
A BOLA vulnerability in GET, PUT, DELETE /admins/{adminId} allows a low privileged user to fetch, modify or delete a high privileged user (admin).
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.004 · Published 2024-07-09 · Fixed CWE-639
Priority MEDIUM 43
A BOLA vulnerability in GET, PUT, DELETE /secretaries/{secretaryId} allows a low privileged user to fetch, modify or delete a low privileged user (secretary).
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.004 · Published 2024-07-09 · Fixed CWE-639
Load more